2019.04-1 update - Subtitle Options Missing from 'Now Playing' option

Just updated my Raspberry Pi to the above version and noticed a couple of small issues.

I have subtitles switched on by default so that they appear for films that have them for foreign language parts. However, for the TV programmes I have, the subtitles are English anyway and I don’t need them.

If I’m watching a TV programme that has subtitles, I would normally press Enter on my remote to bring up the ‘Now Playing’ menu/options. I would then scroll across to the subtitle icon which would then display a sub-menu where I could disable it. Once done, I would then press the back arrow on the remote to return to the programme.

This functionality appears to have been removed and replaced with a separate menu screen, which will only appear if I press Enter twice whilst on the subtitle icon.

1 Like

Can you please let us know what skin you are using and ideally take some photos to show the situation?

What remote are you using? It’s possible the keymapping has changed.


I certainly can, along with any other information about my setup that may be helpful.

OK, the skin I’m using is the Confluence one. The remote is a cheap remote purchased from eBay, with the name ‘PCremote’ on it. The only add-on/plug-in I have is the ‘Missing Movies’ one. I have links to two NAS units, and that is basically it. I don’t use for anything other than watching films and TV programmes.

NOTE: Pressing the Enter key twice to get the subtitle menu up seems to have been solved with a reboot, which I did when enabling debugging for another query.

This is the subtitle option I was referring to on the ‘Now Playing’ menu. Previously, it displayed various options.


And this is the menu I now get when I press Enter whilst sitting on the subtitle icon above:


I’ve just updated OSMC running on a RPI2, and also found the same issue. In the first image in the above post I normally had an icon that would lead directly to the subtitiles download screen. Now I need to go via the download subtitle option on the second screenshot…

Same issue also… The subtitle option via the main menu it’s not practical :frowning: