3D not working properly on 4K+

I’ve spent some time trying to make 3d work, but without any luck (both rips and various samples from https://kodi.wiki/view/Samples).
Event UI is not switching to 3d properly (using Settings → System → Display → Stereoscopic 3D mode / Current).
HDMI cable is from the bundle, but I’ve also tried cable from PS4 with the same results.

Here is how screen looks like in different modes:

Over/Under:

Side by side:

Closeup of left corner of the screen in side by side mode:

Debug log for this process (reboot with debug enabled, cycle through modes, send logs): https://paste.osmc.tv/awosodunaq

Screenshot of “side by side”:

There are no screenshot for over/under because of the instant crash:

Debug logs of the crash (boot, switch mode, TakeScreenshot - crash): https://paste.osmc.tv/uzaloyomof

Any ideas, what can I do next?

What’s the name of the file you’re playing? It needs to have 3D.SBS in the name for it to be recognised as 3D.

Sam

Names are correct (Stereo mode in mkv metadata as well). One of the examples - “Suicide Squad (2016).3D.SBS.mkv”.
It’s correctly detected as 3D, when I attempt to play it - kodi ask for 3d mode (preferred / monoscopic / alternative) and reports correct mode in notification pop-up when playback starts.

Then depending on the resolution, it’s either show frames for both eyes (if interface resolution is set to 4k) or just one (if it’s 720/1080p).

TV does not consider this signal as 3d and only allows to enable built-in 2d->3d conversion.