3D play is OK, but the subtitles display is not

Following instructions I found in the forum somewhere, i disabled the 3D auto playing in OSMC, and use my Sony TV’s options menu to switch to 3D mode.
The video shows perfectly in 3D, but the subtitles don’t.

Hope to have this issue fixed.
Keep up the good work fellows.


Can you take a picture of what you mean?


If you are trying to watch Side by Side or Top / Bottom 3D you should still leave 3D support enabled in Kodi even if you are having to manually switch your TV to 3D.

There are three aspects to supporting 3D on Kodi -

  1. Kodi needs to be able to detect that a file is 3D, and in what format, this is done by inspecting the file contents (some file types - and relies on proper encoding) or looking at the filename extensions. As such it is sometimes necessary to rename the file to get correct detection.

  2. When Kodi knows a video is 3D and what type of 3D it is, it will then render the GUI/menus in a way that is applicable. For example for side by side it should render the entire GUI twice, side by side so that when your TV is in 3D mode you see one GUI in both eyes.

  3. Kodi will try to send an HDMI signal to the TV to tell it to automatically switch to 3D. This requires both hardware and software driver support to work.

Of these, 1 and 2 currently work on the Vero but 3 is not working - I believe it’s only an issue of driver support in the Kernel and will get fixed at some point. This means that for the moment you have to manually enable 3D on your TV at the start of 3D playback.

I actually have the same issue on my Mac Mini (which is my primary device on my main TV) with a DVI->HDMI cable (and analog audio) because the Mac is not able to send the 3D command to the TV, so I have to manually enable 3D on the TV but it otherwise works fine. (I think in the case of my Mac it is a hardware limitation because it uses DVI output)

If you disable 3D support in Kodi 1 and 2 are disabled and you will not be able to read the menus while the TV is in 3D mode. The same would apply to subtitles.

If you look at playback with your TV not in 3D mode you should see two side by side pictures (for SBS format) and two side by side duplicate subtitles. If you only see one subtitle spread across both pictures that is your problem, as Kodi is not formatting the subtitles for 3D display because it doesn’t realise it is playing a 3D file.

Thank you @DBMandrake for your clarifications/sugestions.

I’ll fiddle around with your sugestions this weekend to see if they work.

In sum:
1 - I only have Side By Side 3D files and SBS is an extention existing in the file names on all of them;
2 - All of the files have subtitles in separate files, with the same file name as the video file;
3.1 - As I can remember, if I leave the 3D auto switching in Kodi turned on, the TV doesn’t detect the 3D from Kodi and doesn’t switch automatically to 3D mode. This is coherent with your 3rd bullet;
3.2 - If I then switch the TV to 3D, the file doesn’t get played correctly, it stays with 2 Side by Side versions of the file;
4.1 - The only way I was able to play these 3D files correctly, was to turn the 3D auto switching off in Kodi;
4.2 - But the subtitles remain in 2 Side by Side mode, which is coherent with your last sugestion.

Again, I’ll look into it more closely this weekend. Thank you very much guys.