3D SBS Issues, Vero 4K & LG TV


I just got my Vero 4K yesterday, already having issues with 3D.
When using Stereoscopic 3D / SBS, with the TV set to 3DSBS, the interface is OK, but the image is half-OK and half black.
When playing the SBS-file using 2D setting in OSMC and the TV in 3DSBS mode it works, but the OSMC interface does not.

Any ideas why? I have Googled for hours but nothing seem to work.
Sure, it works if i dont care about the interface or subtitles… but it annoys me.

This is OSMC in 2D mode with SBS source, TV in 3D SBS mode.
Image is OK, Kodi-interface is not.

This is OSMC in 3D SBS mode with SBS source, TV in 3D SBS mode.
Image NOT ok, Kodi-interface ok.

And lastl, this is OSMC in 3D SBS mode with SBS source, TV in 2D mode…
Why the black image?.. looks like SBSBS to me.

Im using Vero 4K running Kodi 17.3, OSMC 2017.05-2

That seems strange. Try another HDMI cable.

Vero 4K currently will not autoswitch video mode. So when you play back a 3D SBS clip, you need to:

  • Select 3D SBS when prompted by OSMC (file has to be named correctly for this to work)
  • Manually enable 3D on the TV.

If you continue to have problems, please post MediaInfo, and try another SBS video to rule out a problem with the clip


I have tried 3 different SBS-sources with the same result. Using the included HDMI-cable directly connected to the TV. And yes, as I said on the image captions i have tested 3D SBS in OSMC and 2D. And manually selected 3D SBS or 2D on the TV since it does not autoswitch.

To me it seems like OSMC does not “split” the image (source) where it should, and creates a black image for the “right half” of the screen. When using my 3D glasses on scenario/image #2 above (OSMC and TV in 3D SBS-mode), my right eye is all black (except for the OSMC interface).
I would call it “Side-by-side-by-side” :slight_smile:

How should I fetch the MediaInfo you want?
Also, the tv is a LG UF852V.


When output as 3D SBS, assuming the video is 3D SBS itself, Kodi won’t touch the image. All it is meant to do (and will later do so) is present the interface correctly and signal the display in to 3D. ppmgr won’t perform any processing on this video.

  • How is your file named?
  • Does Kodi prompt for 3D change when you press Play?

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC

The files are named according to Kodi standard (http://kodi.wiki/view/3D#Video_filenames_flags)
Kodi do prompt for 3D change when i press Play.

I will post the mediainfo later.

Source #1:

Source #2:

Source #3:

They all behave the same way.

Nothing? :slight_smile:
I will try a different HDMI-calbe and different Kodi-skin later today.

EDIT: New skin or cable did not help.
However i found this in the logs:

Jun 24 17:11:32 osmc mediacenter[402]: chgrp: cannot access ‘/sys/class/ppmgr/ppmgr_3d_mode’: No such file or directory
Jun 24 17:11:32 osmc mediacenter[402]: chmod: cannot access ‘/sys/class/ppmgr/ppmgr_3d_mode’: No such file or directory

Any idea if this is related? I dont know the context here, I think this is related to the Vero booting.

I also found this in the Kodi-log, when attempting to play a 3D file in SBS-mode:

17:34:35.040 T:3598783472 DEBUG: CRenderManager::Configure - change configuration. 1920x1080. display: 1920x1080. framerate: 23.98. format: AMLCODEC
17:34:35.044 T:4115329024 DEBUG: [Warning] CGUITextureManager::GetTexturePath: could not find texture ‘noop’
17:34:35.060 T:4115329024 DEBUG: Previous line repeats 3 times.
17:34:35.060 T:4115329024 DEBUG: DeleteRenderer - deleting renderer
17:34:35.060 T:4115329024 DEBUG: LinuxRendererGL: Cleaning up GL resources
17:34:35.060 T:4115329024 DEBUG: CRenderManager::Configure - 4
17:34:35.061 T:3598783472 DEBUG: CVideoReferenceClock: Clock speed 104.270833%
17:34:35.065 T:4115329024 DEBUG: CAMLCodec::SetVideo3dMode:mode3d(0x0)
17:34:35.066 T:4115329024 DEBUG: CAMLCodec::SetVideoRect:display(0,0,3840,2160)
17:34:35.066 T:4115329024 DEBUG: CAMLCodec::SetVideoRect:gui(0,0,1920,1080)
17:34:35.066 T:4115329024 DEBUG: CAMLCodec::SetVideoRect:m_dst_rect(0,0,0,0)
17:34:35.066 T:4115329024 DEBUG: CAMLCodec::SetVideoRect:dst_rect(0,0,0,0)
17:34:35.066 T:4115329024 DEBUG: CAMLCodec::SetVideoRect:m_stereo_mode(0)
17:34:35.066 T:4115329024 DEBUG: CAMLCodec::SetVideoRect:m_stereo_view(0)

Thoughts? :slight_smile:
This was when trying to play a 1080p “Half-SBS” source (#1 above).

Got it working!
I switched to 1080p display resolution in Kodi system settings (instead of 2160p) and now it’s working.
Any idea why and how to fix it? I would like to keep using 4K-resolution since my TV supports it and some of my content is 4K.

Also the TV does not switch to 3D-mode automatically, but this is not a big deal…

1 Like

The 3D autoswitching will come soon enough.

I don’t advise setting the GUI to 2160p. Kodi has a worse scaler than most TVs, so you’d be better off setting it to 1080p and letting the TV do the work.

If you have Adjust Refresh Rate enabled, then Kodi will switch to 2160p when you place 4K content, and flip back to 1080p for everything else



I somehow had to set it to 2160p in the system before to get it to work, but I guess that was before I enabled “Adjust Refresh Rate”.

I tested it and 4K works in 1080p-system as well!, the TV registered the input as 2160p24hz when playing :slight_smile:

Hopefully this thread will help someone else too!

1 Like

Glad this is now resolved.

1 Like