4K content lags abit

Hi, I just bought a new Samsung 40" 4K UHD Smart-TV UE40KU6075 50hz and a Vero4k.
Scanned my content via PlexKodiConnect for Kodi\OSMC

Now almost everything seems to work fine after I adjusted the picture to fit onto my screen.

I have connected vero4k and my TV through a gigabit switch and it only flashes orange so I’m guessing Vero4K isn’t capable of gigabit ethernet.

I am running it on 1920x1080 with an refresh rate of 30 as I read it should automaticly readjust for 4K content once I press play, I Have also tried running it on 3840x2160p but still the same problem persists with 4k content, it somewhat lags making some scenes “slow”. I have also tried different refresh rates.

What might the problem be?
Anyone else having similar issue?

Try posting a debug log.

Do you have Adjust Refresh Rate enabled?
Have you tried playing the content back locally?

Otherwise, the content will indeed look choppy


Where do I turn on Adjust Refresh Rate?

I have tried playing this through my Plex app in Smart TV and it works without a hitch there so far.

Thanks for the fast reply


Under Settings -> System.

If you are running your GUI at 30Hz, and don’t have this option enabled, it’s not surprising the video is quite choppy.

Just to be clear, this is a OSMC\kodi setting? I’m assuming it would be under Display, but all I find is
Refresh Rate
Blank other displays
Delay after change of refresh rate

and I Have my system settings to expert.

I found it and it now works fine :slight_smile:

Awesome and cheap system you’ve produced, will definetly buy another one when I Need 4k\my system in the living room stops working.

Thanks for help

Glad to hear everything is working as expected now.

If you have any further questions, you know where to find us!