4K+ FactoryCodec - Audio: passthrough - Failed

Hi,

I’m having some troubles getting HDMI pass-through working to my Onkyo NR686 AVR from my new Vero 4K+.
I believe I’ve got passthrough enabled, with all codecs, and I’ve disabled “Sync playback to display”.
Passthrough has worked previously for this file on my old Asus Chromebox 2955U version of kodi (openelec, kubuntu etc) to the same AVR.

I’m only seeing 2 channel reported from my AVR as input.

Media info is here: http://paste.osmc.io/qiriyiw ero.tex

Logs after reboot are here: https://paste.osmc.tv/naleh azute
and include the lines:
08:54:34.771 T:3417522944 DEBUG: FactoryCodec - Audio: passthrough - Opening
08:54:34.771 T:3417522944 DEBUG: FactoryCodec - Audio: passthrough - Failed

Any tips as to what I’m doing wrong? I’ve searched the forums but the posts I’ve found have been unable to help me.

Thanks very much,
John

Set channels to 7.1 :wink: AAC will be decoded to PCM. The channel setting is only affecting PCM output and as per your logs you’ve set that to 2.0 atm.

Thank for the reply - that certainly sounds like it will help.

I’m slightly surprised because I swear I had pass-through working for this file with my old kodi box - which was set to 2.0 channels because I read I needed to do this to enable pass-through (which then ignores the 2.0 setting). (I can’t find a good reference for this claim - and they’re probably relics of history now - but here’s a couple of bad ones: sound - Enabling 7.1 audio passthru in 14.04 for Kodi - Ask Ubuntu and https://droidbox.co.uk/how-to/surround-sound-settings-on-your-android-powered-set-top-box/ - though I was also battling pulse vs alsa issues back then. Anyway - I’ll fix the 2.0 setting now.)

So, to be clear - are you saying that 5.1 AAC can’t be passed through to the AVR, and must instead be decoded to PCM by the 4K+? The AVR certainly has AAC decoding capabilities when playing files - not sure about via HDMI.

Passthrough of AAC isn’t possible on any device

Clearly my memory is erroneous then. Thank you both for the help!