"a start job is running for set time using http query"


Out of nothing, I get following message, which stops the boot of my OSMC on rasp pi version 2:

“a start job is running for set time using http query”

This happens since some days… OSMC worked previously without any problems.

This is not an error.

OSMC narrows the time sync that ntpd will have to deal with by initially synchronising with a webserver (bit of a wget hack).

This is probably taking a little longer than usual or your network connection is not ready in time. When this happens again, please upload the output of:

sudo journalctl | paste-log


Sorry, my system does not boot up… it stays within this state forever. Reboot doesn’t help.

Therefore I can’t provide any logs… the system doesn’t ever come up…

Please read Sam’s post where he shows how to upload a log from SSH.

“A start job is running for set time using http query” is a normal message that may appear if it is taking longer to synchronise the time than expected - this could be due to a problem with your internet connection, however it will not stop Kodi from loading, and normally when Kodi does load this message would not appear until after Kodi has taken over the screen, so you would not see it anyway.

If Kodi does not load at all (did you wait at least a minute ?) then there is another issue at play. Do you use a MySQL install ? Do you have “wait for network” enabled ? Any details you can tell us about how your system is set up would be helpful.

If there is a problem we will get it from the log.

Otherwise, as Simon says, there is a different issue here.

When it does not load at all, what do you see? A black screen with this text or the OSMC splash, or even a sad face? Can you take a photo?


I will upload a photo this evening…

tried to log in via ssh but my raspi was not reachable.

The message appears on the boot screen with activated display of details.

It seems that there is no timeout to stop this waiting sequence (unlimited or no limit).

it waits for around 12 mins before the time counter stops without any good happening after


This information and all the stuff on the screen picture does indicate that your OSMC doesn’t have a network connection! How are you connected ethernet or wifi?

that was my first guess… I use Ethernet cables and tried two different with two different plugs in my router. But indeed this is not 100% excluded yet. need to check them with another device. Or may the time server be unreachable?

Nope, as you can see on your picture other network stuff also not reachable like:
“/media/kaisercloud” which is a remote file system

this file system never mounts on boot… that message also appeared, when everything else was fine

The HTTP query is not holding up your boot here and is not the real issue. 22 seconds is fine. Normally. systemd will not display this until either:

  • 30 seconds have elapsed or
  • Another systemd service has degraded. In this case, it is caused by the mounting error.


how could I resolve that error? (without ability to boot… can I read the file system of the sd card in MacOS?) But as I said that message had already appeared when the boot was okay before this error with http appered. and the timer counts til 12 mins…

You could try using a mac to read the SD…also try holding shift during the boot, i think osmc has a safe boot as well…not 100% sure though.
If you manage to get in, or reinstall the OS do use Win32DiskImager-0.9.5-binary when you are done, to backup your img…so in the future you dont pull your hair anymore

The HTTP time service has a built in 60 second timeout after which it will abort. If it says it is still running after 12 minutes then the most likely cause of trouble is almost certainly problems reading or writing to the SD card, causing the entire boot process to hang.

I have seen this issue on an SD card that sometimes “hangs” during disk IO. I would try a different SD card.

but why is the timeout having “no limit” when there is one according to your update?

The systemd service unit doesn’t have a timeout but the script that it runs does:

Next try with SHIFT (seems not to work), now I see alternating messages:

1st that one I told aldready and the same also for “Trigger Flushing of Journal to Persistent Storage”

Interchanging (1-2 seconds each) with prefix “(1of 2)” and “(2of 2)”

Now I want to try to edit my fstab to remove the mount statement… but I’m not sure how to get into the Linux partition? My Mac seems to recognize the Windows partition only.

The tool mentioned above is a Windows tool.

Shift for the recovery console does not work in recent updates unfortunately, due to changes in the kernel.

The message you’ve just posted now, waiting for “Trigger Flushing of Journal to Persistent Storage” only serves to confirm my suspicion that you have an SD card problem.

Have you tried another SD card yet like I suggested ? IMHO you are just wasting your time trying to find a software solution to a hardware problem. The Pi is not able to read or write to the SD card properly, that is why your boot process is hanging in this way.