AAC5.1 playing as stereo (not what you think)

I’m a regular RPi OSMC user, since the model B, and I get confused sometimes on sound settings as I have four RPis with four different amplifiers, and they’re all a bit different with various formats. However, generally speaking, my RPis are setup with passthrough enabled for the sound, and via hdmi they’re setup for 2.0 speakers (the default setting), and they generally play AAC5.1 as 5.1.

Just plugged in a brand new Vero 4K+ and it seems the amp won’t see the AAC5.1 as anything other than stereo unless I do the opposite of what I’ve done for all the RPis and set 5.1 as the output in the audio section of system.

DTS and DD5.1 seemed to be pushed straight to the amp when it was set to 2.0 if that makes any difference.

Is this a thing? Or is there something fundamental I’m missing. It’s a Yamaha ARXA830 (which will shortly be being swapped for an Atmos compatible amp). All the DTS, DD and True HD boxes are ticked as the amp can do all of them.

AAC isn’t supported as a passthrough format as there is no standard for it.

We would send it as LPCM5.1, but you’d need to set the number of channels to this.



1 Like

Thanks Sam, makes sense then.

I was extra confused because I’ve never had the option of which output to use PCM Analogue (default?) or HDMI, so I set it to HDMI and thought maybe I’d done something wrong.

Is it detrimental to other formats that are set for passthrough to have the 5.1 setting enabled by default?

No - shouldn’t cause an issue.

It just means any formats you don’t enable passthrough for will be decoded and streamed as LPCM 5.1.

1 Like

[pops off to do that on four other RPis]

The “number of channels” setting is how many PCM channels, not how many speakers you have. PCM is an uncompressed audio signal which makes it relatively large. AC3 and DTS are standards that compress the audio so they can fit more channels into the same bandwidth as stereo PCM. The passthrough option allows these compressed formats to be sent instead of a PCM signal allowing for surround sound through a two channel connection. As such your also picking which device decodes, and if needed, downmixes to a selected number of speakers in use.

If you have devices that were set as two channels but they played AAC 5.1 in surround then they must have had the convert to AC3 option checked. This is relevant to the topic at hand as this option is only available when the output channels are set to 2. If your configuration is such that it only supports two channels (using Toslink or routing through a TV with this limitation for example) then this is likely the prefered setup.

If your connected to a device that can accept six or eight PCM channels then this is certainly the optimal channel setting as will output surround sound without the AAC signal getting degraded by the recompression into a AC3 format.

I don’t think I’ve ever enabled “convert to AC3” on any of my RPis in the past, it sounds more like I just picked a duff file (AAC) to test my shiny new Vero with.

I expect I’ve normally just switched whichever amp I was using into pseudo surround to get around the problem in the past.

And sorry, yes, I have 5.1 speakers, that’s the only reason I opted for that as I assumed that’s how many PCM channels I’d need.

Thanks though.