AC3 Audio format not passed through from tvheadend on Vero2

HI.

First of all: The work on OSMC from the whole team is highly appreciated! In the name of my family: Thank you all!

I used Kodi in 4 rooms, mostly with RP2/RP3 connected via HDMI to a normal TV. A Synology NAS runs mysql and another server is running tvheadend to stream up to 6 TV channels provided by HDHomerun and DVB-T sticks. All on Gigabit network.

My living room installation is using the vero2, together with a Pioneer AV receiver, 7.1 speaker setup and a BenQ-projector.

All worked well - until one of the latest Vero2 updates.

German TV channels often stream multiple audio channels, like “German MP2”, “German AC3 5.1” or “Germany AC3 Stereo”.

When I watch a livestream with AC3 (passthrough is enabled), than I do not get any audio output. Switching the audio channel to MP2 works (but Stereo only and with little frequent disruptions on the screen).
When I record a stream using tvheadend and watch the record later via Kodi/tvheadend (like Pro7/BigBangTherory which has a AC3 5.1 channel), the audio fails too.
When I copy the recorded file to a network share an open it via kodi, everything works! Including 5.1…

OK - than it’s maybe tvheadend, I thought. So I attached an RP3 to my living room and the Pioneer, and did the same tests again - and - all worked. With latest OSMC and tvheadend on the Pi…

So to me, this seems to be a dedicated Vero2 problem.

Any hints, thoughts and ideas are very welcome!

Thank you in advance

Oliver

Did this occur after updating to Krypton? This is expected behaviour. With Kodi Krypton, passthrough audio support with LiveTV is no longer possible. This isn’t isolated to Vero 2.

There is an experimental hack to re-enable passthrough. I may add it in the future but currently for the best synchronisation, it’s best left to how it is.

Sam

Thank you, Sam, for this quick replay!

I can not 100% nail it down to the update, but most likely - yes. From a users perspective I would like to understand why passthrough audio support has been disabled by design. To me, this seems to be a feature decrease… If you have any hints where I can read about that would be nice.

But to be honest I had the impression that it works correct on a RP3 with latest OSMC. I will go down for the living room and test this again now…

You know, watching live scoccer games without the stadion athmosphere… I think I would really miss something!

Your Pi is probably passing it as LPCM. Vero can do the same but only for 2 channels (or 7.1 on 4K).

There’s some discussion about this here: http://forum.kodi.tv/showthread.php?tid=284580&pid=2385467#pid2385467.

I can add it as an experimental option in a future update.

Sam

OK. I tested the Pi3 again. Any movie, any liveTV stream I was looking, was displayed with 5.1 speaker symbols and the term “Dolby Digital” at my Pioneer. Then I changed back to the Vero2 and the AC3 streams became silent. Disabling Passthrough and enabling DSP results in crazy noise.

I’ve understood your explanation and I read the discussion. You mentioned that the Pi3 is maybe passing it as LPCM. Is this a technically not possible limitation on the Vero2 hardware, or it’s just not coded yet?
Anyway - many thanks for that background stuff. If this experimental option in a future update is possible, you would make big fan happy again.

Thank you for all the quick support!

Oliver

DSP is broken in all versions of Kodi. We’re going to remove it or prevent it from being enabled.
Are you sure your Pi is on the same version as your Vero?

Vero 2 will pass through LPCM of 2 channels. You’d need to downmix for it to work properly.

I can certainly make it available, but I’d like some feedback as to how viable it is. Could you watch a few games and let me know if it works or not?

Sam

Hi Sam.

All seems to be the same version. I’m looking forward to test for you!

Thank you,

Oliver

HI.

In the meantime an update was applied and as a result - even for normal video playback - movies from m library with 5.1 AC3 sound - does not play surround at all. I tested any combination I can think of, but while the previous issue was only related to tvheadend streamed content, now also content from the video library also fails to play with AC3 sound format.
I have not changed anything on my physical layout, but the Vero2 worked very nice in the past. Not getting AC3 at all is not what I expect as improvement.

If no one is someone is having a similar problem, than I think I need to do a “factory reset” of my Vero2 - if I found a guide on how-to…

Any hints, ideas are more then welcome.

Thanks,

Oliver

Not aware of this.
Surround sound via passthrough is only disabled for Live TV, as explained above.

Post a debug log and we should be able to see what the issue is. Also take a photo of your audio settings.

Hi Sam.

Back from travelling - there’s the log:
http://paste.osmc.io/fowujaseti

You can see me starting Dr. Dolitte recorded on TV “ProSieben” at 14:11… This record starts with a Stereo Audio only (advertisement), but switches after approx 2 mins to 5.1 when the movie starts.

As I’ve replaced the VERO2 box with a raspberryPI3 (on request of my family) I can confirm again, that the 5.1 audio coming from the PI3 is working well. The configuration is “Passthrough” and my Pioneer shows 5.1 speakers and “Dolby Digital EX” in the display. But on VERO2 my Pioneer became quite (no speaker symbols) as soon as the audio stream switches to 5.1. Both, Vero2 and the PI3 are running the latest OSMC. Both use the HDMI connection for the Audio channel towards the Pioneer.

And for reference I also uploaded the PI3 Logs doing the same - starting Dr. Dolittle… here:
http://paste.osmc.io/otagorexuc

Please let me know if there is anything more I can do.

Thanks - and happy eastern!

Oliver

Hi Oliver,

I hope you had a good trip.

Thank you for both sets of logs.

I can see that on Raspberry Pi, you have played a recording of a Live TV programme. Passthrough would be supported in this scenario; it is only for Live TV where it has now been disabled in Kodi.

On the Vero 2, did you try and play a recording, or Live TV?

Just to clarify: passthrough will work for recordings on both Vero 2 and Raspberry Pi 3.

But currently, passthrough will not work for Live TV programs on either devices, for the reasons highlighted earlier in this thread.

Raspberry Pi will however decode and send this as LPCM 5.1, which means you will have 5.1 channels (but Dolby Digital will not light up during Live TV). Vero 2 can only send out LPCM 2.1, due to an I2S limitation. However, I will reinstate passthrough support for Live TV for this device only in the next update (April update).

Cheers

Sam

Hi Oliver

I believe this should get things working as expected for you again. It will be released as an update shortly.

Sam

Hi Sam.

This is a great news - many thanks for following up on this topic!
For the moment I’ve switched to the Pi3, but as soon as the update is released I’ll re-enable the VERO2 box.

Thank you again.

Oliver

Was released as part of April update yesterday

OK. MY Vero2 still does not pass AC3 Audio to the HDMI interface if it comes from Tvheadend. My RaspberryPi 3 - does(with the latest updates)! I simply watch recorded episodes of “The big bang theory” on Pro7 with got recorded with AC3 5.1 Audio in tvheadend. I do hope that this will change with the next update - but as Vero2 and Pi3 image should be the same - I doubt. I’ll reinstall the Vero2 image on the vero2 tomorrow and test again. This is truly annoying. I do appreciate Sam’s work and will continue to use OSMC - but with the Vero2 - this was maybe not the right decision to buy this one.

Again - it might be a configuration issue on my side - I’ll never say that I don’t do failures and stupid things. However, I’ve still no clue why my PI3 does pass-through the 5.1 Audio via HDMI to my Pioneer, while the Vero2 does not. The big advantage on the Vero2?- My logitech harmony works with it…

Hi @OLGR

I can passthrough AC3 from Vero 2 to my amp for Live TV and other content without issue since the update. I suspect you need to check your audio configuration.

Also make sure HDMI is selected as the output device and not Analog.
Make sure Expert Settings is enabled to see all audio options.

They’re not the same. They’re completely different pieces of hardware with different audio outputs.
But nothing will change with the next update, because passthrough isn’t being reported as broken by any other users.

At this stage – I think the problem is a configuration setting. If passthrough didn’t work on Vero 2, I’m sure there would be other users (quite rightly) screaming their heads off about this in the forums.
Please post a picture of your audio settings.

I’ve already reached out to you personally so we can get this solved for you.

Sam