Access to SMB shares "Connection Timed Out" -> Restart of Server and it's back. Need to find Problem

Hey there.

I am struggling with network problems since I built my PI2 with OSMC.

HTPC has Argus running and is Windows 7 based. Goes into Hibernate if not busy. Connected via wired LAN.

Client is OSMC latest updates on a Raspberry PI2.

My Music, my video files recorded by Argus and a MySQL Database are stored on my HTPC. The file directories are network shares.

The PI2 is connected via WLAN.

Ok Problems. I have installed at LEAST 20 times now. Everytime the same. Everxthing is working. Music playing. Videos playing. TV Data is there. And then… next day… Nothing happens. “Busy” and in the logs is the Message that the file can not be found. Funny: Synch of EPG and Channel data with ARgus is working. Music and Videos are still shown and listed. So Database connection is working, too.

But if I try the lowest step: Filemanager -> Open one of my shared directories I get immediately “Connection timed out”.

As if OSMC couldn’t find the HTPC. Ping is working, Database and Argus are connected. But no access. After rebooting the HTPC everything is working again.

In addition I got multiple issues with my WLAN adapters since thursday. Edimax Nano: Suddenly network was not reachable. Joining the WLAN was not possible or did last forever. After installing again and again the whole system from scratch on, I gave up on that adapter. When WLAN was set up every menue or setting suddenly was lagging forever.

Original Raspberry PI Dongle: Installed, access to OSMC network settings was fast. It found the WLAN fast. Everything seemed working. After a few minutes watching a video the first time it started to stop for buffering and after half an hour with 5 or 6 buffer lags suddenly sound disappeared.

Now I am using a rather large CSL stick with antennas. This one works without any problems. BUT… Opening OSMC settings --> Network --> Wireless LAN and then I need to wait 3 or 4 minutes without doing anything until the settings appear. Changing a setting needs to wait for 1 or 2 minutes again. But that’s the only problem. Videos are playing etc.

But my old problem still is there… Let the PI2 running yesterday and just wanted to start Music or a Movie. “Connection timed out”. I bet if I restart my HTPC and then the PI it will work again.

Is there a reason why it is loosing the ability to open SMB shares while network seems ok?

So the htpc also is the mysql server? Kodi will not like the mysql server shutting down while it’s still running. This probably has something to do with the media issues.

Logs will be required to chase the wlan issues.

If rebooting your “server” helps you are probably reaching the infamous 20 connection limit of SMB in all Desktop editions of Windows 7:

Note: this is a 20 connection limit not 20 clients. A single client such as Kodi may open multiple connections in parallel for example during thumbnail scanning.

Check your event viewer log to see if there are any notifications saying that the File and Printer sharing service has reached the 20 connection limit.

If it has, this is your issue, and you should consider using something other than a desktop version of windows as a “server”, especially if you are trying to serve to multiple devices.

So much sarcasm… :scream:

Before I spend more money for components for an additional NAS for files and MySQLI am trying with the systems I already got. :neutral_face:

The eventlog tip was really helpful. Thx. Always forgetting about it and forget to have a look. There was indeed an error.

Event ID: 2017
Source: Srv
Type: Error

The server was unable to allocate from the system nonpaged pool because the server
reached the configured limit for nonpaged pool allocations.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache - Set to 1
HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size - Set to 3

For now… Looks like it’s working. Those settings change the cache size. At least it worked this morning and this evening after work without reboot. Will see if that solves my problem.

@ActionA: For the first tests it has to run like that. As long as the PI2 is running the HTPC is not shutting down. Will change that later and put the DB on something power saving which runs all the time.
As of now the CSL WLAN stick is running. It is problematic with the settings, but runs if once set up. I am busy at work this week. But I will try get a set of logs next weekend while putting the different sticks in and opening WLAN settings.

If everything keeps working as it is, I got the WLAN running and the SMB disconnects gone. Hopefully.