Adjust Refresh Rate no longer working since latest update

Ever since the recent update (not the update to Kodi 18, but another one which was automatically installed today, April 25), refresh rate is no longer adjusted as expected with my Vero 4K.

My default refresh rate (when the system starts up and the skin is shown) is 60 Hz. I have “Adjust Refresh Rate” enabled and set to “On Start/Stop”. Previously, when I started a movie with 23.976 Hz frame rate, the display would switch to 50 Hz refresh rate and the movie would play smoothly.

Since today’s update, the refresh rate switch no longer happens for the same movie, and the playback is stuttering. (I have a standard movie I use for this kind of testing, so I am sure that it worked properly before.)

As far as I can tell, this happens both with “Sync Playback to Display” enabled and disabled.

Debug Log:

1 Like

Small update: I rewatched the start of the test movie and I am no longer sure about the stuttering. Nevertheless, the refresh rate change behavior is definitely no longer the same as it used to be.

Anyway, I’d be glad if someone with a better understanding of frame rates vs refresh rates could help me understand what’s going on.


in your logging I find

<setting id="videoplayer.usedisplayasclock">true</setting>

which mean you’ve activated settings->player->videos-> sync player to display

Believing the display capability in the data your tv only can show 1080p at 24 Hz, for all other resolutions it handles 50 or 60 Hz.

So, deactivate this setting and try again.

Btw.: This setting also prevented correct function of audio passthrough.

1 Like

I’ve been having what may be a related issue: my refresh rate setting in Settings/System/Display doesn’t persist. My 60 setting is being reset to 30, and I can see the difference not only in the GUI but in video playback (stuttering…fairly mild, but noticeable). Not sure how to get it to stick. I have Adjust display refresh rate and Sync playback to display set to Off in Settings/Player/Videos, fwiw.


adjust display refresh to ON
sync player to display to OFF

With that you should get the best playback. The gui frame rate is independend from this config but I’ve no idea why your display setting does not persist. Others are welcome to help.

1 Like

That would indicate that you are using the staging repro not the stable one.

Thanks, Jim. So I’m clear, by “On,” you mean “Always?” That’s what I’ve changed it to, and things seem to be working OK, save that I know notice a black screen delay of a couple seconds when starting and stopping a video…I guess because it’s reading the file to determine the refresh rate?

No because your TV need the time to switch resolution/refresh rate.

1 Like

Hi all,

Let me get back to the original topic of this post.

As I wrote in my initial post, I’ve already tried it with both this setting enabled and disabled, with no difference in the result.

Is it visible from the log if I’m using a version from the staging repo? To the best of my knowledge, I have never done anything to switch the repo ever since I got my 4K; from this I am assuming that I’ve always been on the stable branch.

Regardless of whether the TV switches refresh rate or not – can someone explain what the most suitable refresh rate of the TV is for a 23.976 FPS video, 50 Hz or 60 Hz? After all, as I wrote in my follow-up to my initial post, I don’t actually notice a stutter anymore, even though the refresh rate doesn’t change as expected. Could it be that the 60 Hz refresh rate that is set after I turn on my Vero 4K is already the right one for the video, and there is simply no need to switch?

Yes, it is visible from there and it indicates that you are now on the stable repro so all good in that regards

You are indeed on stable.

You are on Kodi 18 (Leia) as that is now the stable release.

The most suitable refresh rate should be 24fps. Kodi should switch to this if you have Adjust refresh rate set to On Start/Stop (recommended) and Sync player to display Off.

Auto refresh rate is broken for me on 720p files. If it is 1080p or higher, it will switch correctly to 24p, but for 720p it will stay at 60hz.

Just looked at the available refresh ratesin the gui for 720p and it only offers 60, 59.94 and 50hz. Rebooting the device does not help. The HDMI chain is unchanged and worked perfectly before (Yamaha RX A1080 + Sony XF90).

edit: after another reboot, it actually does work now. I had the problem before shortly after the Kodi 18 update but one reboot did solve it, so I didn‘t think much of it.

1 Like

I’ve got the same issue with 720p and 24fps files.

The lowest listed in the whitelist settings is 50fps and no amount of reboots changes anything. Kinda annoying as had no problems before the update to 18.

Same issue with 720p 24fps (60hz stay). Files with 720p and 23.976 are O.K.

Logs would be useful…

Here is a log :

Heres mine too

@damir.matacin It looks like you tried to play a 720p file and your resolution was at 1080p. As you do not have resolution whitelisting enabled; Kodi did not adjust the refresh rate.

Your TV does not support 720p24Hz. I’m not sure what your expectation is.

Really? It always changed the refresh rate for 720p 24hz content before the Liea update, it’s an LG B8 OLED.