After october update HIFIberry Digi doesn't function

Hi @JanS
i’ve tried to downgranding of kernel like you’ve suggested
but all the video in dolby digital have been without sound yet (with passthrough turn on)
here is the log https://paste.osmc.tv/uhuyomeyih
thanks.
Bengio

*new version of 11PM

with downgrading of kernel i’ve seen only now that in system / Audio/ audio device there is also “ALSA: snd_rpi_hifiberry_digi, S/PDIF” that before there wasn’t.
i’ve selected this device and now the video in dolby digital has sound with passthrough turn on.

what does it mean?
thanks

Bengio

Hi @bengio
I´m not sure , but if now after downgrading it is working, I think the problem is in the new Kernel which adjusted wrong output for the sound.

[ 4.686495] snd-hifiberry-digi soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry
[ 5.071234] wm8804 1-003b: revision E
[ 5.076901] snd-hifiberry-digi soc:sound: wm8804-spdif <-> 3f203000.i2s mapping ok

Do you have some logs from new kernel 4.19?
I think that “ALSA: snd_rpi_hifiberry_digi, S/PDIF” was also before updating correct. Can you confirm what you have set before update?
Jan

Edit: What you mean *new version of 11 PM? The Kernel 4.14 is older.

Hi @jans
I haven’t log with the new kernel 4.19…

Yes, before upload i’ve setted Alsa…s/pidf
and after upload there wasn’t Alsa…s/pidf but also alsa…analog

Thanks

Bengio

Hi @bengio
Can you make some test with another sd card with libreelec which use also kernel 4.19?
If Hifiberry card working and what is necessary set in kodi?
If it will be working, I hope will be possible to find some solution also for OSMC kernel - but definitely will be necessary some logs from new OSMC kernel 4.19.
Unfotunatelly I have not actually access to Hifiberry card for my test.
Thanks
Jan

Hi @JanS

I am experiencing exactly the same problem with the latest update :frowning:
My logs are here https://paste.osmc.tv/ozukiwowap

Let me know if it’s still necessary to install librelec (I hope it’s not :wink: )

Fallling back to previous kernel version now…

osmc@osmc:~$ sudo apt-get install --reinstall rbp2-image-4.14.78-4-osmc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reinstallation of rbp2-image-4.14.78-4-osmc is not possible, it cannot be downloaded.
The following package was automatically installed and is no longer required:
  rbp2-image-4.14.78-2-osmc
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
osmc@osmc:~$ sudo dpkg-reconfigure rbp2-image-4.14.78-2-osmc
Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.14.78-2-osmc /boot/vmlinuz-4.14.78-2-osmc
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal-osmc 4.14.78-2-osmc /boot/vmlinuz-4.14.78-2-osmc
run-parts: executing /etc/kernel/postinst.d/inform-updater 4.14.78-2-osmc /boot/vmlinuz-4.14.78-2-osmc
run-parts: executing /etc/kernel/postinst.d/process-vmlinuz-rbp 4.14.78-2-osmc /boot/vmlinuz-4.14.78-2-osmc
osmc@osmc:~$ systemctl reboot -i

Digital output is back again together with mutichannel audio :slight_smile:
Thx for help!
Cheers

tiroy

1 Like

I also have the same issue, the 2019.07-1 version allows me to select ‘ALSA: snd_rpi_hifiberry_digi, S/PDIF’ and then output DTS audio to a receiver via passthrough, if I run a manual update to 2019.10-1 (or do a clean install to 2019.10-1), that option disappears and only ‘ALSA: …analogue’ is available, so no audio over passthrough…

1 Like

Hi @tiroy
I think you have not switched on debug mode when you sending the logs:

2019-11-10 11:27:06.122 T:1916077616  NOTICE: Disabled debug logging due to GUI setting. Level 0.
2019-11-10 11:27:06.122 T:1916077616  NOTICE: Log level changed to "LOG_LEVEL_NORMAL"

Second: In the config.txt you have not setup correct overlay (don´t use for setup selection of sound card in MyOSMC addon). Correct is:

dtoverlay=hifiberry-digi

Please check this documentation:
https://www.hifiberry.com/docs/software/configuring-linux-3-18-x/
which I posted in this thread before few days ago
Please try in kernel 4.19 add to config.txt

dtdebug=1

then reboot and after reboot please show us output of:

aplay -l

dmesg

and

sudo vcdbg log msg

Downgrading to previous kernel it is not final solution, because you can not upgrade in the future. (after upgrade you will recieve new kernel again)
Unfortunately I have not actually any hifiberry card to test in libreelec, but I hope, that if somebody with hifiberry install libreelec, we can check if there is working and which packages is installed there.
In Libreelec forum I can´t find any logs about hifiberry and latest version 9.2 Beta 2
Thanks
Jan

1 Like

Hi @JanS

Here’s the requested data, I have executed your setup instructions.
http://paste.osmc.tv/xusicowabi
Cheers

Hi
I´m not sure about these logs. For me looks like new kernel has problem with reading of firmware from HAT EEPROM:

[ 4.541850] snd-rpi-wm8804 soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry
[ 4.551448] bcm2835_v4l2: module is from the staging directory, the quality is unknown, you have been warned.
[ 4.567398] wm8804 1-003b: Linked as a consumer to regulator.1
[ 4.568716] wm8804 1-003b: revision E
[ 4.570005] bcm2835_codec: module is from the staging directory, the quality is unknown, you have been warned.
[ 4.572575] snd-rpi-wm8804 soc:sound: wm8804-spdif <-> 3f203000.i2s mapping ok
[ 4.739733] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[ 4.747256] cfg80211: Loaded X.509 cert ‘sforshee: 00b28ddf47aef9cea7’
[ 4.754449] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[ 4.754461] cfg80211: failed to load regulatory.db

and also change using of overlays between version 4.14 and 4.19

002750.633: Failed to load HAT overlay
002750.700: brfs: File read: 280 bytes
002772.057: dtdebug: Failed to open overlay file ‘overlays/hifiberry-digi.dtbo’
002780.141: dtdebug: Opened overlay file ‘overlays/hifiberry-digi-overlay.dtb’
002780.951: brfs: File read: /mfs/sd/overlays/hifiberry-digi-overlay.dtb
002809.653: Loaded overlay ‘hifiberry-digi’
002809.781: dtparam: audio=off

In system journal log from kernel 4.14 where is working it is writen:

osmc kernel: snd-hifiberry-digi soc:sound: wm8804-spdif <-> 3f203000.i2s mapping ok

in system journal log from kernel 4.19 is written:

osmc kernel: snd-rpi-wm8804 soc:sound: wm8804-spdif <-> 3f203000.i2s mapping ok

Maybe @sam_nazarko can explain it better - some different libraries?

@tiroy could you please post complete debug logs from kernel version 4.19? (System>System>Logging>Enable debug logging), reboot, and send full logs

Thanks
Jan

Unfortunately I don’t have any modern HifiBerry hardware to run on a Pi anymore, so can’t suggest much.

Here they are
https://paste.osmc.tv/ewohilabeh

It can be something similar?


Thanks
Jan

@tiroy Could you add please for some test to config.txt

dtoverlay=i2c-bcm2708

and reboot and full logs?
Thanks
Jan

Unfortunately not.

Sam

Uploaded https://paste.osmc.tv/ukeyovimar

Same problem here. Reverting to the 2019.07-1 image fixes the problem. With the latest kernel the S/PDIF-output is no longer recognized.

Hi @tiroy
I have just one last idea. Could you please try uninstall package alsa-utils ?
It seems,that in version of kernel 4.14 was not this package. Maybe it blocked correct output.
I´m not sure correct command

sudo apt-get remove alsa-utils

This I hope keep setting data for install again if not help.
and reboot

Thanks
Jan

I have installed alsa-utils after I have discovered this problem with latest update, since you asked me to execute “aplay -l” :slight_smile:

Oops :upside_down_face::wink:
Sorry I´m out of ideas.
Maybe now is time to checking logs in libreelec?
Jan

Hi,
I’ve th same problem. I’ve tried everything you all had proposed unfruitfully.
Now I’m trying to roll back to 14.4 kernel but it is not available at all.

osmc@osmc:/lib/modules$ sudo apt-get install --reinstall rbp2-image-4.14.78-4-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package rbp2-image-4.14.78-4-osmc
E: Couldn’t find any package by glob ‘rbp2-image-4.14.78-4-osmc’
E: Couldn’t find any package by regex ‘rbp2-image-4.14.78-4-osmc’

Where can I find it?

Thanks for your great job!!!