After reboot lost SMB and ability to customize home screen

I installed a new additional USB HDD to my USB hub, scanned for content, made a profile for my children, but in the children’s profile I couldn’t customize the home menu, it said I needed to enable the skin helper, so I did but still nothing.
So I then went back to the main profile and the home screen was blinking black screens.
Never seen that before so I rebooted.
Then once back in the main profile I went to see if I could customize the home screen, and I could not.
So I decided to forget about that for now and went to my PC to see why it wasn’t scanning some items into the library and I noticed I was unable to see my drives on my PC anymore.
Samba shares were gone.
Any help please!

Got SMB to come back up.
I turned it off and back on in settings and rebooted.
Interesting though, when I rebooted it booted back up into 720p.
So immediately I went to chang eit to 1080p and when I went to the setting it was set to blankas if no resolution had ever been chosen.
Then when I went to change it my screen flashed off, then came back with a screen asking if I wanted to keep the resolution.
I hadn’t changed anything so I was uncertain exactly what resolution it was asking me to keep it at so I said NO, but then it just kept on repeating thatquestion so I finally said YES.
Then the resolution setting showed 720p as if that had been selected, so I went to it and changed it to 1080p60.
Very strange.
So now I’m trying to figure out why a lot of my TV episodes are now missing from the Library.
As an example I have six season folders of Marvel’s Agents of SHIELD and it only scans in the first three seasons and ignores season 4 through 6.
I try to manually scan those folders into the library but it ignores them.
They are in the same mane folder “Marvel’s Agents of S.H.I.E.L.D” and the only difference between the folders themselves is one character, the season number (S01, S02, …).

Self powered?

It’s on a powered USB 3.0 hub.
It’s a Seagate Backup Plus Portable 5TB that gets it’s power via USB.
The hub has no issues with it.
There’s a Seagate Backup Plus Portable 4TB on there as well.
Powers them fine and speeds are as fast as the Vero’s USB 2.0 will go.

Check debug logs, if the library items can not be found normally indicate a issue with the drive dropping out

I can find the files just fine and play them back without issue on the Vero.
Just something odd about thescanner not getting them into the library.
Does a subfolder called “subs” throw it off?
Structue is like this.

I renamed the subs directory to zsubs so it shows up at the end but still no luck.
I tried taking the idx a sup files out of the subdirectoy and just putting them in with the mkvs, no luck with that either.
My seasons 1 through 5 are ripped from Bluray.
Season 1 through 3 have the subs in the MKV so there’s no “subs” subfolder.
Season 4 and 5 have the subs external in a “subs” subfolder.
Season 6 has subs embedded in the MKV just like 1 through 3.

There’s something silly taht I’m missing here.
What’s weird is that it worked before just fine.

Enable debugging, have a console open with tail -f .kodi/temp/kodi.log start a scan on specific director and you will see why it doesn’t work.

Something has changed with the scanner.
I changed the directories name from “Marvel’s Agents of S.H.I.E.L.D” to “Marvel’s Agents of S.H.I.E.L.D. (2013)” and rescanned it.
Then it grabbed everything.
Previously it was recommended to not put the year behind the TV show unless TVDB did it to distinguish it from different shows with the same name.
Not sure why the change but easy enough fix.

Now to figure out why I can’t customize the Home menu.
I go to settings > interface > skin > configure skin > home > enable menu customisation but it does nothing.

Skin settings > Add-ons says:
Skin Helper Service = v1.1.3 installed
Skin Helper Service Backgrounds = Disabled