Airplay problems using BBC iPlayer and TVPlayer on a Pi 2

I would be grateful for feedback from anyone that has successfully managed to AirPlay video from BBC iPlayer / TVPlayer on an iOS device to a Pi 2 running the latest version of OSMC. Both apps advertise streaming to TV using AirPlay.

I have a Raspbmc config running on a Pi 1 which works flawlessly with iPlayer and TVPlayer. There is no AirPlay conflict as only one device was running whilst testing. Router and devices have all been rebooted.

I have no other issues with Airplay on OSMC on the Pi 2. Kodi (osmc) is always visible in the Control Centre and I can AirPlay DRM free video from Safari and FileBrowser. Airplay Audio works fine as does AirPlay Photos.

My Pi 2 OSMC install is pretty much stock. Kodi settings were mirrored across from Raspbmc by taking screenshots and then applying the appropriate settings in OSMC.

If others are streaming without issues then that may point to OSMC being more sensitive to router settings and I can start looking in the right direction.

Any help would be gratefully appreciated.



Airplay is handled entirely internally to Kodi, so if there is any difference between Raspbmc and OSMC, it is only in the Kodi version. (OSMC is now Isengard 15.1, Raspbmc is stuck on Helix 14.2)

I just tried the BBC iPlayer app on my iPhone to OSMC on a Pi 2 and it worked first time for me on the Doctor Who Series 9 trailer.

Have you tried different clips ? It’s possible that some clips are tagged with DRM and some are not. Kodi of course, cannot play DRM Airplay content.

To go any further we would really need to see a Kodi debug log taken when the failed attempts to Airplay were made.

OK, I’ve identified the problem through the debug log.

The issue is caused by the fact that I route all traffic from the Pi 2 to an OpenVPN service, with point of origin outside of the UK. The routing is handled by an OpenVPN client on my ASUS router. So even though my iOS devices can stream UK TV services, it looks like the server needs to be able to do the same. There’s settings on the router to allow OpenVPN destination exclusions so hopefully I can resolve the problem.

The Raspbmc unit wasn’t affected by the AirPlay issue because I’m running the VPN client directly on the device and using per process routing for VPN bound traffic.

Anyway, thanks very much for confirming the fact that BBC iPlayer works and thus helping me to identify the cause of the problem. A donation has been sent in gratitude.

Now to solve the problem!!!

Ah, yes, that explains it.

Not often realised but AirPlay video simply sends a URL to the server to play. Sometimes that URL points back to a small web server on the sending device (typically port 7000) for locally hosted content but typically for content not hosted locally the app sends a URL that points directly to the original source.

So the AirPlay server must have the same network connectivity available that the client does to ensure all content can play using AirPlay.