Another Sad Face loop

I am having trouble with a sad face bootloop recently.

I’ve tried moving .kodi to .kodi.bak, and I still have the sad face. Interestingly, there is no .kodi folder created, so I don’t even get to that point.

And I’ve tried sudo apt-get update; sudo apt-get dist-upgrade, and still the sad face.

I’ve looked through the forums, and the best solution I’ve found that seems to apply to my situation is to re-install. I’m hoping to find a solution that will get me through for a few months until I have more time to re-install and tweak everything.

My log files are at

Any help would be greatly appreciated.

Your pasted log includes a very long log from /home/osmc/.kodi/temp/ which indicates that either the .kodi directory wasn’t moved when you issued the command or has been recreated since you rebooted. The directory certainly existed when you took the logs.

The logs also show you watching videos, how often do you get the sad face screen?

The log also shows that kodi can’t find at least one USB drive and also that it can’t connect to your tvheadend server. Can you confirm exactly what you’re doing when the sad face occurs?

Thanks yk.

I moved my .kodi.bak back to .kodi before creating pulling log files.

I believe I watched videos 2 days ago, and started getting the sad face 1 day ago and it has been stuck on the sad face since.

If it helps, here is the log from when I moved .kodi to .kodi.bak and booted into a sad face:

I’m suspicious that the problem is mainly with the tvheadend server. I’ll play with that, but in the meantime, if you have any ideas, I’m all ears. Thanks for the help.

The log reveals what appears to be a problem with a haupage wintv receiver.

For now, remove all peripherals and try to reboot.

If that works then slowly add the peripherals back one at a time rebooting after each one until you find the problem.

I tried booting up with no peripherals, no luck; stil sad. Then I tried just attaching network and external hard drive; still sad. I removed the tvheadend startup script from the /etc/init.d folder; still sad.

Any other thoughts?

Thanks for the help.

Can you make sure there isn’t a .kodi directory, remove all peripherals except network, reboot and post a fresh set of logs do we can see what’s going on with nothing attached?

This is the log set after
mv .kodi to .kodi.bak
rm all peripherals
rm tvheadend startup script from /etc/init.d/
apt-get remove samba since I noticed some samba errors in the logs
I’ve also put the sdcard in my linux machine and ran fsck on it; I’ll run a more thorough scan on it overnight and report back.

I’m pretty baffled at this point. Thanks for the help so far; let me know if you have any other ideas from this set of logs.

The logs reveal that kodi is stopping with a segfault (error 139). They also reveal you have some non-standard software installed such as OpenVPN and ClamAV.

I think there are three things you can try:

  1. Change gpu_mem_1024 to 144 in /boot/config.txt and see if kodi can create a new .kodi directory then. (It is possible the kodi doesn’t have enough RAM with ClamAV running also.)

  2. Reinstall install kodi using sudo apt-get install --reinstall rbp2-mediacenter-osmc (If 1 doesn’t work it is likely that kodi is corrupt)

  3. If all else fails and no-one else has any ideas, you may have to re-install OSMC.

You probably don’t want to run ClamAV on your system!

I’m curious as to why we are seeing that obviously some packages such as ClamAV and X11 have been installed yet it would appear as if the apt term.log has been edited as there is not indication there. What else is “missing” from these logs?