Any chance to get these things back to work after the Kodi 18 based update?

I updated to the latest OSMC build based on Kodi 18 just 2 days ago.
First thing I noticed, and that is something many others confirmed already, is that Shadertoy stopped working - both the screensaver and the visualization.
I read that some people recompiled it with some obvious success but since I never compiled anything in my life except music, can someone please tell me if there’s just a simple update download which makes this working again?
By the way, I already tried this (sudo apt-get…):
but OSMC doesn’t find any sources except for spectrum.

Second, the weather app stopped working. First no any weather showed up (I was on Yahoo weather as source), then when I switched to Open Weather Map Extended, the weather kind of came back but only for the current weather - no any forecast anymore.

Folks, I understand that this is open source and I fully respect the effort people put into this, but heavens - what at all had been tested before release of this?
I use OSMC since a couple years now, but this seems to be the worst build for now.
OK it got a bit more responsive but for what price?

All I can do for now, and that is what I’ll definitely do is reverting to my image from last January,

Shadertoy add-on doesn’t work with Kodi v18 anymore. I think @popcornmix is quite busy at the moment; but he may be able to revisit in the future.

Yes – we tested it thoroughly; as did many users who participated in nightly and test builds. There will always be issues with a major update; but the plan is always to address them as promptly as possible.

Did you try refreshing the add-on repository and updating the weather add-on you are using?

If you can elaborate in more detail what isn’t working; then I am sure we can fix it.


Thanks Sam for the fast response.

OK so Shadertoy is dead, at least for now. What a pity.
Any alternative around?
I want my TV screen to switch to some animated foreground (preferably with random animations) when I either listen to music or as a screensaver.

Then about the weather app: As I said, the forecast is completely gone. Instead of icons for every day for the forthcoming week, all I see is one icon which shows the current weather.

What I also noticed is that now OSMC became unresponsive on some commands.
For instance, you press OK or play at an app, in order to play something back, instead of doing so, OSMC jumps into the context menu or simply does nothing, not even when you try to repeat the command.

Since I think I am quite good in analyzing bugs, I would be willing to act as a beta tester for OSMC and/or Kodi. Can you give me the right hint where to register for that and hence, get access to the update sources?

EDIT: one more thing which is not available anymore: Even OSMC displays the Germany keyboard layout would be active, my Umlauts disappeared.

Add-ons need to be updated by their maintainers to support newer versions of Kodi. This can take a bit of time to occur.

The Shadertoy add-on does not work on any v18 system and this is a known issue.

We don’t maintain these add-ons ourselves, and it would be very difficult for us to keep track of the many add-ons available. You may wish to stick with Kodi v17.6 for now – a download of which is available on the website.

We ran Kodi v18 test builds for two years: Testing - OSMC Forums. Now we have moved to providing Kodi v19 (Matrix) test builds so we are well prepared for its release.

Some keymaps have changed. It’s hard to speculate without knowing what remote and remote profile you are using.


Regarding the weather addons, they have always been kind of a moving target. The weather providers pretty frequently change what they will provide to free users. There is a forum section on the Kodi site specifically for weather addons:

I looked through some of those threads, and here’s what I found.

1- Yahoo just changed their API. The developer of the Yahoo weather addon is looking into making changes to support the new API. (look at the last page of the thread for that conversation)

2- Open Weather Map Extended has been depreciated. The OWM folks changed what data they will send to free users, so you’ll only get current weather, no forecast (as you noted).

3- The suggested replacement for OWM Extended is

P.S. none of this is related to the Kodi 18 update. The Yahoo API change was just unlucky timing, and OWM Extended was depreciated I think before Kodi 18 even went into beta. Your best bet is to check the Kodi weather forum periodically to try and keep up to speed on things.


There’s an update for the Yahoo Weather add-on that fixes the issue.

1 Like

For instance, you press OK or play at an app, in order to play something back, instead of doing so, OSMC jumps into the context menu

This seems to be due to a change in the default keymapping for Kodi. A longpress on the enter key [or equivalent] takes you to the context menu.

This does make sense, as it gives access to the context menu for remotes without needing a special key mapping, but is a bit surprising when you don’t expect it.

Shorter presses on OK will avoid this, but of course it doesn’t help with the other problem you’re seeing.

OK just done: Latest OSMC image available on the download page installed.
Now first one I noticed, and that is probably an easy one even though I haven’t found a recent entry about it:
Even though I installed and configured the Yahoo Weather add-on, the Weather menu item does not show up on the OSMC default skin.
What to do?

Found it myself:
Had to change to the Kodi skin (Estuary) to enable the Weather menu item, which brought me to the Yahoo Weather configuration wizard once more.
Same for the German keyboard layout: In the Estuary language settings, still English was defined. Switched to German, then went back to the OSMC skin and now both issues are solved.

EDIT - There are new problems though:

  • I recently used Total Commander in order to connect to OSMC using SSH. Now that I changed to this new OSMC version that doesn’t work anymore. When I try to connect via Total Commander I get the following message:
    “Error … Unable to exchange encryption keys”
    Any advice on that?
    Note that terminal/console access via Putty works.

  • In many situations, my Enter key from the keyboard is not being recognized when I press it, regardless whether I choose the English QWERTY or the German QUERTZ layout.
    In such a case, not even the OK button of my remote control is being recognized.
    Any idea what’s going on?
    Further up Sam mentioned it might have something to do with the remote profile used. Where or how can I check this?
    And then again, why is this happening for both USB keyboard and remote control?

I have the same problem with Total Commander in the latest OSMC version,
In a previous version it worked.

Sounds like Total Commander doesn’t support up to date encryption or key exchange methologies.
Suggest to first check for updates from Total Commander

Any advice to or an alternative for Total Commander?
With OSMC 2020.03-1 the problem still exists, and often it is just so much better to access the file system from Windows directly, for modifying or transferring files.

Well you could install the Samba Server from the App Store and then access it from Windows Explorer.

If you want to stick to SSH/SFTP you could use Filezilla

For Windows (Microsoft not App Store) there is a commercial app available called LAN Drive, for a bit more than USD 4.00
I guess I will give FileZilla a chance, or maybe can find another solution which allows SSH conncetions via the Windows Explorer.

Thanks for the hints :wink:

I was referring to the OSMC App Store. Just install Samba Server from there and you can access your OSMC device directly from your Windows Explorer.

Puh, I guess after installing the Samba Server on the Pi I have to enter something like this in my Windows Explorer window?

smb://[The Pi’s IP or name]/home$

Or do I have to specify the port as well somehow?

Maybe you can enlighten me a bit, I am afraid I need a baby lesson here

\\<IP of Pi>\ then you should get the list of shares.

OK I can indeed see the OSMC and the USB device in the Windows Explorer now, however when double-clicking on one of them I am prompted for a user name and password.
Then I try to use the one which I also successfully use via Putty or at the Pi console, however I always get “Access denied”.

Please ignore: just noticed SMB is still demanding the default password.
Now it works and I will change the password accordingly.

Thanks a bunch!

SMB password is independent from system password. You change it with smbpasswd.