App Store addons installation failure — RC2 on Model B

Hi there!

I have installed fresh RC2 on my RPi model B (512M), and have a problem with Samba server installation from App Store — it fails on “Starting Installation” phase with the following popup:
“OSMC Update Error
Error installing:”

After closing the popup window, the system notifies:
“Update
Operations successfully completed.”

Then I tried to install FTP server and I’ve got the same result.

I’d appreciate for your help.

Please provide logs demonstrating failure of the functions you describe.

https://osmc.tv/help/wiki/logs

Here all the logs — http://paste.osmc.io/ekeyiguvak.vhdl (2.1 MBytes)

Your system journal is full of hundreds of messages saying the Ethernet link is constantly going down and back up again. (Search for eth0 in the log)

Check that your ethernet cable and connection to your switch works ok on another device such as a laptop, if so the most likely cause of the problem is that your Pi’s power adaptor or power cable is inadequate, as low voltage will cause the USB controller and Ethernet controller to fail.

If you have a voltmeter you could also try measuring between TP1 and TP2 when the problem occurs - if it’s below 4.75v that’s your problem.

Hmm, I had not thought of that because my SSH connection was being stable. I measured voltage as you advised (4.68V) and discovered that the reason is [HDMI to VGA]-converter, that worked well on my previous RPi B (256M), but seems consuming too much power for 512M board - that’s why Eth link gets down on high CPU loads. So I need to replace that converter with the one providing external power.

Thanks a lot for your help!