Apple Remote (silver) MENU Button, does not work anymore as BACK Button as before OSMC's February Update

Apple Remote (silver) MENU Button, does not work anymore as BACK Button, as before OSMC’s February Update.

Any suggestions?

Thank You


This is also happening with my ATI RF Remote (5000022000).

Same issue on the white apple remote, menu button does not work.

I can use Yatse via WiFi and works to back out.

Edit: appears to work during playback of videos, but does not function during the normal menu operation through the rest of the Kodi menu’s. There is no back or menu elsewhere.

Same issue here. Have an Apple remote and a Logitech Harmony where the Menu-Button behaves similar to the back button - but won’t get me back to the main menu. Can’t get out of certain situations, like when using the Confluence Skin and not having set the default screen after startup - it hangs practically in the Media choice and you can’t shutdown the device.
This is happening on the Vero v1 and 3 Raspberry PI’s with Apple remote.

OK - so I actually fixed it for me (Kind of Fix) by modifying the lirc-configuration file the apple-remote (white).
`osmc@osmc:/etc/lirc$ diff -uN apple-white-A1156-lircd.conf apple-white-A1156-lircd.conf.orig
— apple-white-A1156-lircd.conf 2016-02-25 13:38:03.309194679 +0100
+++ apple-white-A1156-lircd.conf.orig 2016-02-25 13:37:52.253559826 +0100
@@ -39,7 +39,7 @@

  •      KEY_ESC                 0xC0
  •      KEY_MENU                 0xC0
      end codes

end remote
restart osmc and I’m able again to access/exit current situations/menu’s - which I could not before.
I loose the context menu, but on my gym/threadmill I don’t use it.

Either your conf file wasn’t original or your diff is reversed, because there is no KEY_ESC in the original file:

          KEY_UP                   0x50
          KEY_DOWN                 0x30
          KEY_LEFT                 0x90
          KEY_RIGHT                0x60
          KEY_OK                   0xA0
          KEY_MENU                 0xC0
      end codes

I know - that’s why the KEY_MENU is in my +++ apple-white-A1156-lircd.conf.orig 2016-02-25 13:37:52.253559826 +0100 file.

So you have changed it to KEY_ESC then ? Sounds like Jarvis has changed the definition of KEY_MENU…

Most of our remote profiles do not use KEY_MENU so most aren’t affected. If you find a key code that does work correctly for you (sounds like KEY_ESC is not ideal) let us know and we can update the profiles.

Correct. I changed it from KEY_MENU to KEY_ESC. Don’t know if it was Jarvis which did it, or the lircd part.

It will be Jarvis. We have not changed eventlircd or lircd in any recent updates.

Ok. Then, for the sake of those using the Apple remote (white), please change it back ;}

I don’t follow what you’re getting at.

I’m saying that we (OSMC devs) have not made any changes to lircd or eventlircd recently, deliberate or otherwise, therefore the issue you’re seeing can only be due to changes made by the Kodi devs in Jarvis - most likely the Kodi default (system) remote.xml or Lircmap.xml has been changed - I haven’t had any time to look at them to see what might have changed.

So we will need to update some of the remote profiles to match this change. It’s just a matter of finding the time to do this and test with the remote’s in question to find the best fix. Of course anyone else is welcome to figure it out and submit a Git PR or just let us know what they did - remote profiles are one of those things that are difficult to test without having the actual specific remote on hand to test the functionality in different parts of Kodi.

In the meantime, applying the change I did helps.

Well, I have the RPi2 and two ATV1.
This issue doesn’t exist on either the ATV1’s, just on this RPi2.

That’s because ATV1 uses atvremote and not LIRC.


1 Like

I attempted Smurphys fix as outlined below, but unfortunately I cannot report the same level of success with my ATI Remote (5000022000).

Is it possible for me to have lirc report where it is getting it’s config values from? I made the changes to the only .conf in the /etc/lirc/ directory that made sense to be likely- atilibusb-lircd.conf. That file states it’s for the 5000024000 model and I was going on the assumption that it was close enough to count.

So that said- does anyone want to suggest a next step? …if I can get this to work I can promise a PR against the repo. I’m a big fan of submitting PRs.

Lirc uses the profile that you selected in My OSMC remote’s. So which profile have you selected ? If you have not selected any profiles at all, the OSMC remote is the default profile.

At a more technical level, profiles listed in My OSMC remote’s are all .conf files in the /etc/lirc directory, and all selecting a profile in Remote’s does is change the lircd.conf symlink to point at the chosen profile and restart the lircd service. For example:

lrwxrwxrwx 1 root root 32 Jan 1 1970 lircd.conf -> /etc/lirc/osmc-remote-lircd.conf

Okay, well. I changed skin, went into remotes and made sure that the aitlibusb was the selected profile, made the menu->esc change again but am still getting the same result.

While grasping at straws I checked the OSMC default remote and didn’t see either KEY_MENU nor KEY_ESC in the list of buttons.

For what it’s it’s worth I have Smurphys above fix ready to be PRd, just trying to get this sussed out so I can submit them both at the same time so there will be two less remotes to research and fix :wink:

Correct. That profile was made for OSMC - some of the other profiles have carried across from Raspbmc and much older versions of XBMC so probably need updating.

Changing KEY_MENU to KEY_TITLE is probably what is required but without a remote on hand to test or a confirmed fix from a user who has one we are reluctant to make changes we can’t test.

I tried poking at this, but I need to sleep.

For the purposes of collating materials: AppleWhite Remote: KEY_MENU-> KEY_ESC by M-Pan · Pull Request #281 · osmc/osmc · GitHub