Apple Remove (silver) main OK button not functioning after coming from Raspbmc


I finallly got round to making the upgrade over to OSMC - nice work Sam (et al)!

I brought over my lircd.conf for my Apple Remote (the default conf never worked for me) and I have got it working fine for moving left and right etc, but the center button does nothing.

Is there a change to the commands that OSMC is expecting, and/or maybe my lircd.conf file is a bit fragile? See below.

begin remote

name /home/pi/lircd.conf
bits 8
eps 30
aeps 100

header 9063 4442
one 591 1633
zero 591 532
ptrail 589
repeat 9068 2208
pre_data_bits 16
pre_data 0x77E1
post_data_bits 8
post_data 0xDE
gap 108045
toggle_bit_mask 0x0

  begin codes
      KEY_UP                   0xD0
      KEY_DOWN                 0xB0
      KEY_LEFT                 0x10
      KEY_RIGHT                0xE0
      KEY_ENTER                0xBA 0x20
      KEY_MENU                 0x40
      KEY_PLAY                 0x7A 0x20
  end codes

end remote


Worked a treat! Thanks :smile: