Audio dropouts

Got it. It is the same thing then. I suspect i will have to tweak the alsa settings to get the usb-dac to work properly. Is there a primer that I can get up to speed on?

I solved the audio drop out problem by preventing the processors dynamic clocking control from going too slowly. Add


to config.txt in the boot partition and re-boot. The values may need a bit of tweaking as it will depend on where the audio is being decoded (ARM or GPU).

Sorry to jump on the end of this thread. I am a very experienced OSMC user, recently had to install 2 more Rpi’s built the same as all the others. Using the latest release just a few days ago. All media is on a central NAS, MySQL for Libraries and there are 9 clients sharing it. 6 Rpi’s OSMC and 2 Fire TV Sticks running Kodi 1 Linux.

I have sound stuttering on the 2 new Rpi’s. Reading through this thread seemed to point to network issues. Have tried wifi connection, wired connection. Bypass any local switches and wired into the main switch (the one that the NAS is on) into the main switch. Nothing seems to make a difference.

I tried rebuilding the pi’s from scratch. These 2 seem to be noticeably slower than the previous ones. Menu refresh etc. They are Model B 3+ units.

Had previous items in the same network ports that worked fine no sound dropouts. All other clients work fine and are responsive and play media perfectly.

All units update automatically so should all be running latest versions. Is there a particular log file you need to look at. Excerpt below with full debugging enabled and component logging for audio I could not see anything obvious.

12:59:48.511 T:1330123520 DEBUG: GetMovieId (smb://USERNAME:PASSWORD@TWHGNAS/TV/Banshee/Season 2/Banshee.S02E06.SD.TV-Armies of One.mp4), query = select idMovie from movie where idFile=10596
12:59:48.527 T:1330123520 DEBUG: GetEpisodeId (smb://USERNAME:PASSWORD@TWHGNAS/TV/Banshee/Season 2/Banshee.S02E06.SD.TV-Armies of One.mp4), query = select idEpisode from episode where idFile=10596
12:59:48.569 T:1886384896 DEBUG: CAESinkPi:Drain delay:99ms now:0ms
12:59:48.569 T:1886384896 DEBUG: CAESinkPi:Deinitialize
12:59:48.570 T:1886384896 DEBUG: CAESinkPi:SetAudioProps hdmi_stream_channels 0 hdmi_channel_map 00000000
12:59:48.575 T:1886384896 DEBUG: COMXCoreComponent::Deinitialize : OMX.broadcom.audio_render handle 0x5cb4b4d8
12:59:48.576 T:1886384896 DEBUG: CActiveAESink::OpenSink - trying to open device PI:HDMI
12:59:48.576 T:1886384896 DEBUG: CAESinkPi:Initialize Format:24 Channels:2 Samplerate:48000 framesize:8 bufsize:19200 bytes/s=384000.00 dest=PI:HDMI
12:59:48.576 T:1886384896 DEBUG: CAESinkPi:SetAudioProps hdmi_stream_channels 0 hdmi_channel_map 00000008
12:59:48.577 T:1886384896 DEBUG: COMXCoreComponent::Initialize OMX.broadcom.audio_render input port 100 output port 100 m_handle 0x5cb4b4d8
12:59:48.578 T:1886384896 DEBUG: COMXCoreComponent::AllocInputBuffers component(OMX.broadcom.audio_render) - port(100), nBufferCountMin(1), nBufferCountActual(2), nBufferSize(19200), nBufferAlignmen(16)
12:59:48.579 T:1886384896 DEBUG: CActiveAESink::OpenSink - SinkPi Initialized:
12:59:48.579 T:1886384896 DEBUG: Output Device : HDMI
12:59:48.579 T:1886384896 DEBUG: Sample Rate : 48000
12:59:48.579 T:1886384896 DEBUG: Sample Format : AE_FMT_FLOATP
12:59:48.579 T:1886384896 DEBUG: Channel Count : 2
12:59:48.579 T:1886384896 DEBUG: Channel Layout: FL,FR
12:59:48.579 T:1886384896 DEBUG: Frames : 2400
12:59:48.579 T:1886384896 DEBUG: Frame Size : 8
12:59:48.582 T:1895908096 DEBUG: CActiveAE::ClearDiscardedBuffers - buffer pool deleted
12:59:48.587 T:1355289344 DEBUG: Previous line repeats 1 times.
12:59:48.587 T:1355289344 DEBUG: CVideoPlayer::HandleMessages - player started 1
12:59:48.587 T:1355289344 DEBUG: CVideoPlayer::SetCaching - caching state 3
12:59:48.587 T:1355289344 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
12:59:48.587 T:1355289344 DEBUG: CVideoPlayer::SetCaching - caching state 0
12:59:48.587 T:1355289344 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
12:59:48.588 T:1355289344 DEBUG: VideoPlayer::Sync - Audio - pts: 554090666.000000, cache: 261333.353067, totalcache: 500000.000000
12:59:48.588 T:1355289344 DEBUG: VideoPlayer::Sync - Video - pts: 553970083.000000, cache: 50000.000000, totalcache: 100000.000000
12:59:48.588 T:1403073280 DEBUG: CVideoPlayerAudio - CDVDMsg::GENERAL_RESYNC(553829332.646933)
12:59:48.588 T:1403073280 DEBUG: CDVDAudio::Resume - resume audio stream
12:59:48.588 T:1895908096 DEBUG: ActiveAE - start sync of audio stream
12:59:48.732 T:1895908096 DEBUG: ActiveAE::SyncStream - average error of -45.288418, start adjusting
12:59:48.732 T:1895908096 DEBUG: ActiveAE::SyncStream - average error -0.288418 below threshold of 30.000000
12:59:48.976 T:1411461888 DEBUG: CVideoPlayerVideo - CDVDMsg::GENERAL_RESYNC(553829332.646933)
12:59:49.738 T:1403073280 DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-30246.947806, adjusted:-30246.947806
12:59:53.592 T:1411461888 DEBUG: CPullupCorrection: detected pattern of length 1: 41708.33, frameduration: 41708.333333
12:59:57.026 T:1925638656 INFO: CheckIdle - Closing session to (easy=0x6fd0c038, multi=0x5cb4f6c8)

While stuttering no error or other anomaly detected in the log.

Any help appreciated.

Current config.txt modified after reading through other posts maxing out the Freqs.



Is Adjust Refresh rate enabled?


It was off, tried it in all three options. Still get drop outs seems to be worse with Adjust Refresh rate on.


Can we get full logs?


I will refresh my memory on the process for complete logs etc. and get them over to you.

Many thanks for you attention to this issue. It seems to be affecting only the new ones the older ones work fine.

I have also noticed that these 2 fail to update and display.

OSMC Update Error Dialog
Error Installing:

Please report this on the OSMC forum.


I just tried to enable debug logging. Rebooted as per instructions.

Pi now trapped in a Sad Face loop. Ui Pops up for a second then sad face again. Never seen this before.

Maybe these 2 just have a bad build on them.


Well upload logs via ssh grab-logs -A than can see what causes your sad face

OK stated again with a completely new install vanilla settings apart from Debug logging enabled.

Played Independence day movie. Dropouts start almost immediately and continue throughout playback. Does not matter what movie or TV show I play dropouts occur on all. This media plays perfectly on other units some much further away on the network.

Uploaded logs whilst movie was playing.


Ok so I uploaded full logs. Any advice or comments please.


22:41:53.959 T:1569719040 DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-14020.151079, adjusted:-14020.151079

Enable Adjust Refresh Rate


Yes tried that. All of the other devices have that option off and play fine. It improves slightly but I still get dropouts and black frames every now and then.


Can you post a fresh log with it enabled?
Can you also post a log from a different device where it just works so we can compare settings?