Audio fails randomly

So here a weird one, I’ve recently done a clean install of the most resent osmc and now audio while I’m watching a movie or TV show in my library will stop but video continues. I’ve got all settings in menus set correctly to output to hdmi. If I stop or pause playback audio will come back.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thank you, very new to providing logs so I’ll try to update soon.

Here’s a second log with a different movie

You have audio output set to “HDMI and analogue”.
Can you try with it just set to HDMI (or analogue) and check if problem still occurs.

Switched and still happening. Found if I toggle between audio tracks sound will come back after dropping. It’s almost as if it just decides to stop reading the audio track. This is happening with mkv 264, mkv 265, mp4 etc all video formats I’ve tried repeat the same error.

Also try ed different file systemanager format for external USB hard drive exfat master boot record, exfat extended journal, ntfs. All reproduce same audio drop error.

Does it work when you play the file from the SD Card instead?

Most of my filestuff are above 15g they won’t fit on my SD card

Can you set audio output the analogue and listen with headphones - do you get the same failure?
Any different if you enable omxplayer in video/acceleration settings?

Haven’t try ed the headphones will do that next, switched hdmi cabes with no change, have enabled oxmplayer with no changes, audio still drops.

so far no audio drops with analogue, sounds like (no pun intended) a HDMI coding issue.

1 Like

forced hotplug HDMI and testing resumes… update later

That didnt take long… hotplug not the fix :frowning:

If anyone else can/wants to reproduce this error Im testing on pi3 with OSMC build from here, bluray ripped with makemkv, and a powered usb hard drive connected directly to pi3.

Tryed clean install again today same audio drop same results with forced hdmi. All files for on PC and can even get them to play on a Sony bluray player. All attempts to get them to play on OSMC have failed :frowning:

Update I switched to LibreELEC system fully works no tweaks. Id prefer to stay with osmc but look like that’s not happening with the current build.

Did you spend same time using LE?
Did you test the same files?

Was firmware the same on both versions? Can’t think of anything OSMC specific in this regard.


Been using LE for three days no issues so far. There are a few GUI settings I miss, but it seems to be a lighter build. Boots faster on Pi3 plays all files thrown at it so far. Unsure about the firmware.