Audio or video out of sync with DVD files on RPi2

Since about one month I have problems playing DVD files from my usb hdd. Never had this before, i guess it happened after an update. I have seen some talk about people who have same issues in september, but i do not see a solution. I have update OSMC to latest version. I checked my TV already, switched off receiver…nothing worked. It seems sometimes the video frames are lagging…how is this possible on SD material…Any help appreciated!

Can you check if you may have lost the codec key in config.txt, that seems what happen to someone who reported a similar issue.

Hi, I never used/bought a codec key because it worked good already. The RPi2 should be fast enough for SD files I read.

Depends a bit on the SD material and what else the PI is busy with.
But if it worked before without the codec than this might not be the issue

I just don’t understand… in the summer it worked flawlessly. Is there a way to hard reset OSMC?

There is not a direct reset function. If you believe the behaviour is related to an update (and not any add-on or App that you have installed) then you would need to download an older image from https://osmc.tv/download/images/ and install it via the installer. Ideally do it on a spare SD card or otherwise make a backup before writing the new image on the card

Thanx! I will try that soon. if somebody else has an alternative solution, i would be happy to hear it…