Audio settings

I have a Vero 4k+ connected to a new LG CX TV with no other audio equipment.

I have tried to follow the audio setup wiki. There is one thing left which is bugging me. To get the “Dolby Atmos” to appear on a Atmos-supported media file, I have to untick “Sync playback to display” in Player settings. When I then choose a file which does not have Dolby Atmos sound, I get a “audio not supported” message from the TV and I have to manually tick “Sync playback to display”.

Is there a way to get this to happen automatically without having to manually tick the box? Do I have a TV setting wrong?

Sync playback to display should not be used with a TV. Please posts logs so we may see how you have configured your settings. This would be the most advantageous way of figuring out where the issue lies.

Not done this before so bear with me if this is wrong. izidenulap

Please select the all configs and logs option so I can see your edid and guisettings

Oops. Let’s try this:

This is what you TV is showing as supported

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/96/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz,  bit
Dobly_Digital+, 8 ch, 32/44.1/48 kHz, 16 bit
MAT, 8 ch, 48 kHz, 16/20 bit

Change your output configuration to best match, Disable DTS and DTS HD passthrough and set sync playback to display to off, These changes with the rest of what you currently have set should play all audio formats. If there is still an issue please specify what audio format is not outputting audio.

Just a FYI, with the exception of the Raspberry Pi’s the sync playback to display option disables passthrough audio.

Thanks very much - that has worked. I have a Pi on my upstairs TV - was getting confused somewhere along the way.

1 Like

I will remove Sync Playback to Display shortly as it causes some confusion.

1 Like