Audio sound at the movie start

Hello,
since the last update my Vero 4K is not working properly anymore. When I start a movie, want to change something, or just disconnect the power, it bangs out of my subwoofer. Right loud. HDMI cable swapped, other input from the receiver taken, always the same. Any idea?
Greeting Ralf

Set audio output to PCM.

Wow, that was the mistake. Thank you very much!

Not a mistake. A bug which will be fixed in the next update.

OK:sunglasses:

Are there any more information about this bug? I’ve had “poping” sound coming from random speakers during playback for a while now, wonder if it is related. Never happens at the same time/spot in content and some days i never hear it.

Have you already updated to the July update?

If yes and if the issue is still there, could you please provide logs (How to submit a useful support request) and give us some information about your setup (which amp/TV is you Vero connected to, connected by HDMI/S/PDIF, etc.)?

Hello, I have uploaded the July update and the bug is gone. Connected via HDMI to a Marantz 7010. I’m not home until Friday, then I could post a log.
Greeting Ralf

If the bug is gone, it should be fine… Would be interesting to know whether @n4orcer’s bug is also gone now.

I’ll dig through the logs to find the relevant timestamps when we have heard the noise. It’s very strange as it’s random in which speaker the noise comes from, where in an video and if at all it will trigger in a video, it started around January or possibly December and have come and gone since then.

I’ve done tests some time ago where it happened 4-5 times within 30s, stopped the video and restarted and then it was fine for the videos duration.

My setup:
Vero4k HDMI -> Onkyo TX-SR876 -> Surround System and HDMI Video Output to (TV / Projector)

Audio Config:
HDMI Passthrough
‘Best Match’
Auto Refresh Rate = On
Keep sound alive = Off
Low volume noise = Off

I can post the settings.xml, if needed when i have gathered the logs, i’m not at home right now so I cant test, but i do have access to logs etc.

Do note that I yesterday switched to the test versions of '18 and heard the noise once after that switch. I’ve changed from Passthrough to PCM Output to see if that does anything after that happened.

Below example logs are from the last time it happened yesterday before i upgraded to '18 Test builds.

I got a message from my fiance at 17:03, that the noise had just happened. The only thing I can see that looks weird compared to other videos where it didn’t happend if I remember correctly from looking at the logs a few days ago is the ‘ActiveAE::SyncStream’ items, it’s also a bit strange the lines that state ‘CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2’, it should output all the channels to the reciver, granted my fiance other tends to set listening mode to ‘All Stereo’, but the same noise happens regardless of the Listening Mode on the Receiver and the Receiver shows that it’s getting the full channels.

KODI Logs http://paste.osmc.io/igeconurun.vhdl

Edit: Playing the same content in PLEX casted through the Receiver and a Chromecast have never displayed this issue, nor is playing games on Xbox or PS4. It seems to only happend on the Vero4k and mostly on Tv-Shows, very rarely on Movies (but it have happened).

Have you tried disabling trakt to see if that’s the culprit?

Hmm no I havn’t actually.

Do you think that could play a role in this? I can disabled later today and see if it behaves better.

It could be from the looks of the log… Maybe it’s worth a try.

I’ll do some tests in an hour or two when i’m back home. Curious why though, if it does seem to help. :slight_smile:

Could it be that it’s putting to much load on the system or whats the reasoning?

Well, it looks like it’s active during playback. It’s normally preferred not to have too many additional background processes during playback. :man_shrugging:t2:
But it’s just a good guess now. Let’s see…

Didn’t watch that much content yesterday and I did not experience the error, i did disabled the scrobbling feature of Trakt. There was one loud “thud” from the subwoofer at one point, but i did not get any logs from that event and it happened as I was quickly switching between modes on the receiver.

I will continue testing later tonight and let you know if it happens again and provide logs, i’ve also sent an request to the manufacturer of the receiver (Onkyo) as the earlier versions of this model had bad HDMI boards, but supposedly mine was manufactured after it was fixed, long shot since no other source outside of the Vero4k have this issue.

I just wanted to give an update on the issues i’ve been having. I’ve now watched quite a bit of more content through the Vero4k, while running tail -f kodi.log and nothing strange came up in the logs when the noise started to come back.

I’ve done a deeper dive on the receiver end and the version i’m on do have issues with the DSP boards, a software upgrade (I’m on an old SF version) or replace boards may solve this issue.

So does not seem to be an issue with the Vero4k, or something the Vero4k is causing. I will continue doing some tests, if the issue is gone while running in ‘Pure Audio’ or ‘Direct’ modes, thus bypassing the DSP then it’s the receiver at fault, and then I will think if it’s worth spending the money to send it to a service center and try to fix it, or just buy a new receiver that i’ve been thinking about anyway (That Marantz 8012 is sooo tempting!).

Just to understand correctly… You’ve disabled Trakt and not had a problem since then? If so, why would you suspect the AVR to be the culprit, if it’s been only occurring with the Vero and not with any other connected source?
Sounds to me like Trakt has indeed been the problem, if you’ve disabled it during the testing now. :thinking: Maybe the Trakt addon has some option to let it only do its work while there’s no playback?

No the other way around. :slight_smile: I disabled Trakt’s playback scrobble and still had issue, the logs confirm that trakt was not active now the last time it happened, trakt is now only active when you have watched something and stopped. :frowning:

No errors at all or any sync issues show in the logs or anything special going on at all at the time, CPU load on the vero4k was low too, so I don’t think it was a load issue. There is seems to quite a bit of issues with the DSP board, that’s why i’m starting to suspect the receiver more and more.

I don’t use the other sources much, so it’s hard to say that it’s only Vero4k that have the issue, the Vero4k get’s a lot more use compared to the other sources by a pretty big factor.

I’ve now set it to ‘Direct’ mode, which bypasses the DSP board and functionality, if during the coming days/next week I don’t hear the issue at all, it must be the receiver that is at fault.

1 Like