Audio started skipping

OSMC Pi3 connected via HDMI. Files are playing from USB drive connected directly to Pi.

Audio just started skipping whilst playing video files yesterday. I checked and saw that the system hadn’t updated in a long time, so I manually updated, but the problem remains. The issue occurs regardless of the codec playing. I’ve got a six-year-old desperate for a Star Wars marathon while we’re locked in, so all help is much appreciated!

log -

Please, and thank you :slight_smile:

Your log shows that you have four USB drives attached to the Pi.

/dev/sdd1       3.7T  741G  3.0T  20% /media/Media Drive 3
/dev/sdb1       1.9T  1.8T   25G  99% /media/House Media Drive 2 TB
/dev/sdc1       3.7T  3.6T   75G  99% /media/New Media Drive
/dev/sda1       1.4T  759G  639G  55% /media/Genesis Drive of Doom

Are they directly connected to the Pi – or are you using a powered hub?

Blockquote Are they directly connected to the Pi – or are you using a powered hub?

They’re connected with a powered hub.


2020-03-28 23:24:56.966 T:1350128352 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

You could try adding a video cache:

These are the settings I used to use on my pi:


Not sure how much help it will be for usb drives, used to use it for network shares; but wiki advises buffermode 1 does local file systems aswell.

If that doesn’t help, I would consider trying a different psu for the pi.

Thanks Tom.

You could try adding a video cache:

Thank you for the idea, but this did not help. Just for grins, I plugged the drive directly into the Pi to see if the hub was the issue, but it was not.

By psu do you mean power supply?


1 Like

Is that likely to have just “gone bad” between one day and the next?

Hardware degrades over time. At some point, one day has got to be the day.