August update no sound even if stero upmixed disabled

Hello there.

This is a vero 4k+ device
After upgrading to 19.1 sound stopped working. Not only playing any video but the sounds of the interface also.

Here are the logs:

I’ve seen similar problems in the forum but none apply to me.

The vero is connected only to a TV through HDMI and is setup with 2.0 so no stereo upmixing option is aviable (I tried to put 5.1 to see if messing with that setting could have sound but no luck)

Also removing .kodi folder does not work. Attached logs are already with a clean .kodi folder (I think, i messed up a little with some tries and I erased by mistake by forgetting to stop mediacenter service)

Anyway… Any help will be appreciated

Please remove pulseaudio:

sudo apt-get remove --purge a2dp-app-osmc pulseaudio-module-bluetooth pulseaudio
sudo dpkg -r armv7-bluez-alsa-app-osmc
sudo dpkg -r armv7-bluez-alsa-osmc
1 Like

thanks, that did the trick. Although i had pulse in order to stream via bluetooth (not that it worked well anyways…)

That has now be replaced by the new bluez version without pulseaudio

thanks for the info