August Upgrade Issues

So you are also experiencing a black screen when entering Videos?

Sam

No sorry, I do not have the same issues as OP, the topic was just: August Upgrade Issues. I am having August upgrade issues in that I cannot upgrade. when I try via the osmc settings add-on, I get the aforementioned error. It may be worth noting that i am on 3.18.13-1-osmc kernel as the newer kernel did not allow my tv tuners to function. So; could this be a factor causing the update error? and a follow up question: will the update again make my tuners (RTL-2832) non-functional?

If your issue is not the same as OP, please stop hijacking his thread and create your own describing your own issues and the setup you are using. Thanks

Give the dist upgrade a go. I believe the tuner is still broken upstream, yes

I have only ever used the skin that was distributed with OSMC. The system upgraded in July, whatever version was upgraded at that time is what I have previous.

Please use the log uploader in MyOSMC and provide the link returned. We have no way of determining what the issue is if you are only giving us the symptom without any kind of debug info.

I would if I could, but the Log Uploader feature does not work. Nothing happens on screen, one of the many menu items that is not working. Can I get the logs by SSH.

I tried to reinstall, not sure if I am doing it right but started off with sudo apt-get update , but it is hanging up on reading package lists.

Looks like you’re using WinSCP, click on the Commands tab at the top then Open in Putty, from there run your commands,

EDIT: You may need to install Putty

Thanks, was successful in re downloading the packages but stuck on reinstalling

“are you root?”
Obviously also apt-get autoremove would need to be run as root sudo apt-get autoremove

But the mainpoint is you have not executed the right command at all for a dist-upgrade!
Login OSMC and exectue
sudo apt-get update, this has to run thru smoothly, if that already is not working that you have either a problem with your SD card (broken or no space) or your internet connection.
If that command was successful then run sudo apt-get dist-upgrade. After that is successful and you have done a reboot you can then do a sudo apt-get auto-remove.

Please notice I would suggest only do a sudo apt-get dist-upgrade from within a screen session, so first you have to install screen with sudo apt-get install screen and then start a new screen with “screen”

It will work fine in the Putty session, definitely run update and dist-upgrade in that order

And yes, you need to run the commands with sudo

Ok using sudo and the commands are executing properly but not getting very far. Honestly I am in a area I am not that familiar with. I thought I was removing the previous (Aug) upgrade and reinstalling. Followed the steps in order you outlined.

If you ran sudo apt-get update
before running the dist-upgrade command then it would indicate that you are already updated to the latest

I thought that was the proper order, you posted earlier "run update and dist-upgrade: in that order. I get the feeling it’s broken or I have completely botched it up.

Maybe I need to do a fresh install on the SD card using the installer. if I do so, is there a way of restoring my settings from a earlier OSMCBACKUP_xxxxxxx.tar.gz backup

@Bryan what @Dilligaf is saying that if you have run “sudo apt-get update” with success and then you run “sudo apt-get dist-upgrade” and the result is as your screenshot shows “0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded” then all updates have been done and you are using the latest OSMC.

So reading thru the thread I think there were some mix ups with the other poster.
So now we assume you are 100% updated, you use OSMC skin (you said you never used any other one). My suggestion enable debugging do a restart go thru the menus with the Black Screen and post your logfiles. If you can not do that from MyOSMC do it from ssh (refer to https://discourse.osmc.tv/t/how-to-obtain-provide-necessary-info-for-a-useful-support-request-includes-current-versions/5507)

also bryan if the black screens make it hard to find menus try
xbmc-send --action=“ToggleDebug”
to enable debugging from ssh session

and my apologies if I confused the issue earlier

1 Like

Thanks all, my mistake. I thought autoremove rolled back the previous installation. Able to create a debug log but had to copy it over to my working OSMC box and use the log uploader. Hopefully it has worked. I could not figure out the pastebin :rage: .

Kodi.log

out of curiosity, have you tried a different skin, confluence comes installed with osmc, just not activated. Not too experienced at reading logs, but it looks like it is having trouble loading the osmc skin files.
ssh in and try:

sudo nano /home/osmc/.kodi/userdata/guisettings.xml

my skin is called mimic. find the section as below and change skin.mimic (or in your case skin.osmc) to skin.confluence

  
        false
        Default
        
        skin.mimic
        SKINDEFAULT
        SKINDEFAULT
        0
        resource.uisounds.confluence
        10000
     

then ctrl+x and y to save
sudo reboot

if this helps perhaps it is possible to uninstall the osmc skin and reinstall it? or who knows, maybe try out some other skins from all the great skinners out there.
Or I could be completely wrong (not unheard of :wink: )
if this doesn’t help simply reverse the process changing skin.confluence back to skin.osmc if you like

Thanks but no luck, what was strange is when I changed skin.osmc to skin.confluence in the entire file it would revert back to skin.osmc. And I tried it twice saving and checking.

What did work was The Fix

Good to know you got it sorted