August Upgrade Issues

out of curiosity, have you tried a different skin, confluence comes installed with osmc, just not activated. Not too experienced at reading logs, but it looks like it is having trouble loading the osmc skin files.
ssh in and try:

sudo nano /home/osmc/.kodi/userdata/guisettings.xml

my skin is called mimic. find the section as below and change skin.mimic (or in your case skin.osmc) to skin.confluence


then ctrl+x and y to save
sudo reboot

if this helps perhaps it is possible to uninstall the osmc skin and reinstall it? or who knows, maybe try out some other skins from all the great skinners out there.
Or I could be completely wrong (not unheard of :wink: )
if this doesn’t help simply reverse the process changing skin.confluence back to skin.osmc if you like

Thanks but no luck, what was strange is when I changed skin.osmc to skin.confluence in the entire file it would revert back to skin.osmc. And I tried it twice saving and checking.

What did work was The Fix

Good to know you got it sorted