Autofs not working on fresh win10 install


#1

I upgraded my pc the other day (new cpu, mobo, ram etc) but cant seem to get autofs shares working again.
They worked fine on my previous win10 install
I input …

mnt/film/sw2 -fstype=cifs,rw,username=al,password=xxxx,iocharset=utf8,uid=osmc,gid=osmc ://192.168.1.88/sw2/ Like before but when i navigate to the share on the vero /mnt/film i cant open the sw2 folder inside the film folder.

I have the folder shared on win10 correctly .
Am I missing something really obvious with security or network settings in windows??


#2

First would suggest tto run smbclient -L 192.168.1.88 to check if the shares are visible as sw2
Then stop autofs and run manually to see debug information.

sudo systemctl stop autofs
sudo automount -f -v -d

then do ls -lah /mnt/film/sw2 and post the debug output.


#3

When I try to run smbclient -L 192.168.1.88 I get -bash: smbclient: command not found


#4

sudo apt-get install smbclient


#5

I tried that last command and get
After this operation, 1604 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Abort.
When I hit y it aborts

I also reinstalled OSMC so the vero is pretty much stock


#6

This would be very strange. Did you try again?

Anyhow if you don’t get smbclient installed try the debugging first.


#7

Ok somehow i manged to get sudo apt-get install smbclientto install.
When I ran smbclient -L 192.168.1.88 it asks for password which i enter as osmc

WARNING: The “syslog” option is deprecated
Enter osmc’s password:
protocol negotiation failed: NT_STATUS_CONNECTION_RESET


#8

Try adding -m smb3

Also are you sure you have user osmc on your Win10? Otherwise -U to add user


#9

Spent all day on it and couldn’t get it working. reinstalled win10 AND OSMC
I think its windows not allowing access to the share folder.
It worked fine before and im just doing the same thing I did before.


#10

So did you try with -m smb3? What was smbclient saying then?
What was the debug output of autofs?


#11

Sharename Type Comment
--------- ---- -------
ADMIN$ Disk Remote Admin
C$ Disk Default share
D$ Disk Default share
E$ Disk Default share
G$ Disk Default share
H$ Disk Default share
IPC$ IPC Remote IPC
sw2 Disk
Connection to 192.168.1.88 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available


#12

So smbclient is working!
What is autofs debug saying?
Could try to add vers=3.0 to your autofs cifs line


#13

debug… Im not sure what any of it means.

osmc@osmc:~$ sudo automount -f -v -d
Starting automounter version 5.1.2, master map /etc/auto.master
using kernel protocol version 5.02
lookup_nss_read_master: reading master file /etc/auto.master
do_init: parse(sun): init gathered global options: (null)
lookup_read_master: lookup(file): read entry +dir:/etc/auto.master.d
lookup_nss_read_master: reading master dir /etc/auto.master.d
lookup(dir): dir map /etc/auto.master.d missing or not readable
lookup(file): failed to read included master map dir:/etc/auto.master.d
lookup_read_master: lookup(file): read entry +auto.master
lookup_nss_read_master: reading master files auto.master
do_init: parse(sun): init gathered global options: (null)
lookup(file): failed to read included master map auto.master
lookup_read_master: lookup(file): read entry /-
master_do_mount: mounting /-
automount_path_to_fifo: fifo name /var/run/autofs.fifo–
lookup_nss_read_map: reading map file /etc/auto.smb.shares
do_init: parse(sun): init gathered global options: (null)
mounted direct on /mnt/film/sw2 with timeout 15, freq 4 seconds
do_mount_autofs_direct: mounted trigger /mnt/film/sw2
st_ready: st_ready(): state = 0 path /-
statemachine:1500: got unexpected signal 28!
st_expire: state 1 path /-
expire_proc: exp_proc = 4100977744 path /-
expire_cleanup: got thid 4100977744 path /- stat 0
expire_cleanup: sigchld: exp 4100977744 finished, switching from 2 to 1
st_ready: st_ready(): state = 2 path /-
st_expire: state 1 path /-
expire_proc: exp_proc = 4100977744 path /-
expire_cleanup: got thid 4100977744 path /- stat 0
expire_cleanup: sigchld: exp 4100977744 finished, switching from 2 to 1
st_ready: st_ready(): state = 2 path /-
st_expire: state 1 path /-

Just goes on and on .


#14

My gut feeling tells me some typos in the config.
Provide the URLs of
cat /etc/auto.master | paste-log
cat /etc/auto.smb.shares | paste-log


#15

Wait. adding vers=3.0 to the autofs cifs line (when i worked out what that is and how to add) worked.
I dont know why it needs to have it included now when it didnt before but at least it works again

thanks. :slightly_smiling_face:


#16

Most likely protocol change as part of the update.