Avahi/Zeroconf not working with new router


I recently spent time with my Raspberry Pi B again and installed OSMC. So far so good, everything including AirPlay and other services was working fine.

However, I wasn’t satisfied with my setup yet and tried Noobs with Raspbian as well, so I did a lot of reflashing. Yesterday I came back to OSMC only and think that that is what I want.

The first time time I tried OSMC – when everything was working fine – I was at my parents house. Now I’m back at my own flat again and am running into some network problems.

I noticed something wasn’t working as it should when the Kodi Remote App for iPhone didn’t automatically find Kodi, although Zeroconf was enabled. I could connect by entering the IP and am able to control Kodi, but it wasn’t automatically found.
Next thing I noticed was that the AirPlay-Icon wouldn’t pop up on neither my iPhone nor my iPad.
Last thing which is bugging me: I setup an external HDD as a TimeMachine for my mac. I can connect to the shared directory, however it is not displayed automatically in Finder as it was before.

From what I have googled so far I guess it has something to do with Avahi-Daemon and my Router. I am also not able to connect to OSMC using osmc.local instead of the IP.
Do I have to enable something on the router or do you guys have any other suggestions?

Thanks in advance

Sounds like your router is blocking bonjour/avahi announcements, without those you won’t be able to use airplay, or connect via osmc.local.

Unfortunately this is going to be highly router specific - you’re just going to need to look through the router documentation or do some googling for your router to find out what needs doing for Airplay to work. I’m sure you won’t be the first person to experience this issue with your model of router.

If it has an option to enable/disable multicasting then you need that enabled, however most consumer routers don’t give you the option to turn off multicasting anyway.

Also make sure you are not connected to a Guest wifi network - guest networks will segregate you from the main network and not allow any device to device communication, only internet access.

Thank you alot.
Before I did most of my troubleshooting directed at OSMC and my Raspberry Pi as I didn’t even know the name of my router.
But it looking for the name was worth the trouble because I did find something. I had to turn off something called WMM in the Wireless-Section of my router. Now everything’s working again, from AirPlay to host.local to the TimeMachine folder popping right up.
Thank you, appreciate your great work! Love this media center.