Backing Up Kodi

I’m running OSMC on a Pi 3. I have Kodi installed on a Fire Stick in the other room and I just want to duplicate my setup. Am I able to use the Backup Add-On from my OSMC set up and then “restore” my Firestick using the same Backup add-on? I backed up my settings to an NAS, but when I went to restore it on the Fire Stick I browsed to the location I backed it up to but couldn’t find the file.

The backup utility in the My OSMC add-on packages the selected files in a gzip. This add-on is not available to other platforms to use as a way to automatically restore. You can pull the files out of this archive and then move those files to your Fire Stick. I have never tried this myself but I would guess that you might have issues with a .kodi/userdata/guisettings.xml going from OSMC to another platform. If you manage to get the files transferred and Kodi crashes when opening that file will probably need to get deleted. You will loose your system settings but I think everything else in Kodi should work if your using Kodi SMB or NFS paths.

I have a Chromebox running LibreElec. I might try backing up that one as well. When I ran the Backup Add On it seems to do what it’s intended, but when I went to restore the Firestick there’s nothing to restore from. It’s just an empty window.

I’m not sure what you mean when you say “I went to restore the Firestick” what your running to try to do this. Did the backup option in My OSMC not make a .gz file? If so then I vaguely recall their being some limits to where this could be backed up to but don’t recall what they were right off.

You really don’t need to use the backup utility at all for this. You could just copy the files directly at /home/osmc/.kodi and then on the Fire Stick use ES File Explorer to moves these files.

Sorry for the confusion. I’m not using the utility within OSMC, I was using the Backup Add-On from the Kodi repository. From what I’ve seen that only seems to work on the device the backup was made on.

I see. I had not used that previously. I installed Backup 1.1.3 by Rob Weber on one of my RPi’s running OSMC and did a uncompressed backup to a SMB share and that backed up exactly how it was suppose to. I then pulled my userdata on a Windows box so I had a fresh empty Kodi. I then installed the Backup add-on, pointed it to my SMB share, and told it to restore. What I was left with at this point, and after restarting Kodi, was a working library, missing add-ons, no profiles, and a no settings which were stored in guisettings.xml (which is a good thing in this case and expected as this is not something you can normally replace with Kodi running. It then dawned on me that the settings in the Backup add-on were for both backup and restore so I checked the rest of the boxes and told it to go again. That got things a bit closer but add-ons were not enabled and profiles were not enabled. So basicly the backup seems fine but the restore has limits. I would expect Kodi on a Fire Stick to act much the same as Windows.

I then dumped my Kodi folder on Windows once more, opened Kodi so it made new default files, and then with Kodi closed I manually moved the files from the Backup replacing anything that was there. After this Kodi was fully the same as my OSMC box. I assume the Backup program has limitations trying to do the restore with Kodi open.

As such I would check your NAS to see if the backup is actually there. If not check the add-on’s settings and try again. Alternatively you could manually copy them instead of using Kodi. Once you have the files then I would use ES File Explorer to copy these files instead of trying to do it in Kodi on the Firestick.

I feel like I got closer to success. The backups show up now, but at the conclusion of the restore nothing is different, and clicking on a menu item results in a black screen. I thought I remembered someone saying you needed to quit Kodi from the app manager on the Fire Stick and restart it, so I’m going to try that.

If your manually copying files then you would probably need to quit Kodi from the app manager BEFORE you replaced its file. You probably will also need to delete guisettings.xml as previously stated (kodi will automaticly replace it with default settings) when Kodi is not running.

So I got it to work finally. The trick seems to be backing up in an uncompressed format, making sure the settings match exactly in both devices in the Backup Add-On, performing the restore in the Fire Stick, exiting Kodi and going to the app manager, forcing Kodi to quit, and then opening it back up again. Everything is working the way it should, and it worked using both the Pi running OSMC and the Chromebox running LibreElec as the “master” devices.

1 Like