Backup hangs - Raspberry Pi2

Everytime I try to make a backup it hangs on a (seemingly) random point. For example, the first time it stopped with a language module of the lastfm addon. Now it hangs on the lib folder of shoutcast.

When checking the debug log I noticed the following error:

WARNING: FileNFS::OpenForWrite() called with overwriting enabled! - //Stuff/Exclude/OSMC/Woonkamer/201507220732/addons/

This matches the progress as indicated by backup so I guess this error should explain why the backup hangs.

Cancelling does not work, so I have to run systemctl stop mediacenter to get KODI working again.

As also shown by the debug log, I’m using a NFS share on my NAS as a destination and a backup folder appears with some content until the backup stopped. I’ve checked the NFS permissions in my Synology DSM center, but it clearly states read/write so for now I can’t see what could be wrong there.

I hope that someone can help me to get backup working again, as I really prefer this scheduled backup over a manual one. Thanks!

Some info of system:

Raspberry Pi2
All connections are wired
SDCARD install of OSMC
OSMC 2015.06-1

I cannot see a link to your debug logs.

You should look at the logs on your Synology, as there may be a clue as to what the error is there.


Indeed, no logs linked.

Also, try not backing up the addons, see if that helps.

Thanks for the replies.

I’ll configure the log linking later today when I’m back home.

At this moment I only have SSH access and the NAS logfile didn’t show any error. It will probably need to be configured for NFS logging…

The error seems to be quite common and it is also mentioned up in the Backup addon thread at the KODI forum:

but without a solution…

Until now, I’ve found three possible causes:

  • Backup hangs when trying to write files over 64kb
  • Problems with writing files containing certain characters
  • No write permissions (which shouldn’t be the case here)

I’ll also try a workaround by using a SMB share instead of NFS.

I’ve configured Backup to use SMB instead of NFS and now it’s working fine. :smile:

No idea though what was causing the problem with writing to NFS. Probably one of the possible causes which I mentioned earlier.

Uh, you have not made it clear whether you are using the backup feature in My OSMC or the Kodi Backup addon - two completely different pieces of software!

It sounds like you are using the Kodi Backup addon not our OSMC backup option in My OSMC, if so you are probably best asking for help in the support thread for that addon.

Until now I wasn’t aware an OSMC version so it was the KODI Backup addon…

I’ll certainly try the native version after the troubles with the current version.