Backups

Hi there,
Looks like there’s something wrong with creating backups from the OSMC configuration app.
Every time i manually or automatic want to create a backup i get the message “Insufficent diskspace at target location”
I tried different locations (usb and local network) for the backups but no luck. Diskspace is more then sufficent ofcourse.
Bug? or is it me?

OSMC on Raspberry Pi-2

Hansipi

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Can we see the output of df -h

Bit late but here it is:

Filesystem Size Used Avail Use% Mounted on
devtmpfs 362M 0 362M 0% /dev
tmpfs 367M 5.2M 362M 2% /run
/dev/mmcblk0p2 7.0G 5.5G 1.1G 84% /
tmpfs 367M 0 367M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 367M 0 367M 0% /sys/fs/cgroup
//192.168.178.21/Public/Backup/OSMC 1.8T 828G 1003G 46% /mnt/backup
//192.168.178.11/osmc 6.9G 2.4G 4.6G 34% /mnt/pimk
/dev/mmcblk0p1 240M 20M 220M 9% /boot
/dev/sda1 932G 791G 142G 85% /media/Elements
//192.168.178.21/Public/Shared-Videos/ 1.8T 828G 1003G 46% /mnt/netwerk-opslag
tmpfs 74M 0 74M 0% /run/user/0
//192.168.178.21/Public/Shared-Music 1.8T 828G 1003G 46% /mnt/music

1 Like

Backup location is on a usb drive: /media/Elements/bu
Tried every other path but no luck

Without debug enabled logs demonstrating the issue there is no other help we can offer.

1 Like

You are right ofcourse, Still found this:

14:21:30 3604.640625 T:1777730544 DEBUG: OSMC BACKUP: : - local required disk space: 3252853443
14:21:30 3604.641113 T:1777730544 DEBUG: OSMC BACKUP: : - local available disk space: 1159942144
14:21:30 3604.646973 T:1777730544 DEBUG: OSMC BACKUP: : - Insufficent diskspace at target location

Available diskspace is however: [quote=“hansipi, post:4, topic:13191”]
/dev/sda1 932G 791G 142G 85% /media/Elements
[/quote]

142Gb at the target location: /media/Elements/bu

The error is that the OSMC Backup looks at the availeble disk space LOCALLY. Not at at the target location

So perhaps the answer is that we need lots of local disk space to create a backup?

Thanks!

A backup that would be larger than 1.1gb seems a little excessive.

Yes, the backup is first created locally before it is copied on the destination disk

I just backed up two Pi’s and restored them on new SD cards. I had setup osmc on random cards I had around the house after loosing 2 a few days ago, received the new cards today and backed up everything and restored it to the new Pi card and it went perfectly.

Just to note my backup was 1.2GB, this is of course with thumbnails etc.

So the message “insufficent diskspace at target location” should be “insufficent diskspace on local drive to create backupfile” to avoid confusion. :confused:

1 Like

@karnage sounds about right

I just ran into this same “insufficent diskspace at target location” error on the Vero 2 when running a backup.
The cause, as mentioned above, was due to insufficient space on the local nand drive, not the actual remote target drive.
After uninstalling 2 skins I was evaluating, and disabling the backing up of thumbnails, (to reduce the backup size), the backup completed successfully.
The error message is truly misleading. @Karnage

We’re going to improve it :slight_smile:

Rather than improving the error message would it not be possible to create the backup directly to the target location? That way one wouldn’t need to clear data off the SD card in order to generate a backup and it would also facilitate backing up of an installation were the SD card to go read only in a fault state.

Or is that not possible?

That’s the plan in the future.

2 Likes