Bad ethernet performance on Raspi 2

I switched my Raspi2 from OpenElec (V4.0.8) to OSMC (RC2). Now the ethernet connection to my homenet is very slow. With OpenElec, I had a transfer rate from my PC to the Raspi of about 8MBit/s, with OSMC there is only 400kB/s.
I changed back to the SD card where OpenElec is installed and the transfer rate is as high as it was before (8MBit).
Is there a known issue with the ethernet connection on Raspi2?

No known Ethernet issues here. What are you using to judge this transfer rate (i.e. what action, protocol etc)


No known Ethernet issues here. What are you using to judge this transfer rate (i.e. what action, protocol etc)

I copy a mpg-File (4GB) via SCP from my PC to the Raspi:

scp <video name>.mpg osmc@

SCP is always going to be slow. You should be using FTP (install the FTP Server from the App Store).

Sorry, no. The same command on the OpenElec installation is as 20 times faster as on OSMC. So it is not problem with scp.
I copied my whole video and music collection with scp and I never had such a slow trasfer rate.

In that case, you’ll need to upload full debug logs so we can have a look at the problem. But that still doesn’t avoid the fact that you should not be using SCP for file transfers. I am curious if you’d still experience slow speeds with other protocols, so I would appreciate it if you tried that.


Ok I will try FTP.
Which kind of logs do you need?

dmesg, syslog / journalctl



4861655040 bytes sent in 3687.28 secs (1.2574 MB/s)

Faster, but not as fast as with OpenElec.

In the log files there are no relevant information about ethernet / ssh / ftp / anything other, neither on my PC nor on the Raspi

Let us be the judge of that?

Your speed is definitely very low, and abnormal. We would’ve had more reports if it was typically this slow, so something’s definitely not right here.


Hi Sam,

here the log files. Sorry about my last post, but I’m using Linux for over 17 years now and I think I do know if there are important log entries or not.

Syslog on my Desktop
dmesg on my Desktopn (last 2 days)
dmesg on the raspi

on the raspi there seems to be no syslogd or journald.

The system log is accessible via journalctl

osmc@osmc:~$ journalctl  
No journal files were found.

See if you can get ifconfig output too. May show if you have any network issues.


sudo journalctl (you must be root)

ifconfig on raspi
ifconfig on PC