Black screen only if I power on the Vero 4K before the TV


My Vero 4K is on the dev repo, and since the last update, I noticed that I need to switch on the device after the TV has been powered on, otherwise the screen remains black and the no signal message appears on the screen. Is like the TV is not getting the signal correctly once the device is on. Only if I keep the device on all the time (and I don’t want to do that), the TV gets the signal immediately when I switch it on. I tried this with two different TVs, and it’s the same thing (those TVs have no problems with other video devices). So, to recap, if I power on the Vero 1st and the TV 2nd, I get no image. If, while the TV is on, I power off and on the Vero, I get the image. Oddly, when there’s no image, I can’t connect through SSH either. So it’s almost as if the device freezes when the TV is off???

Can you upload some logs via My OSMC?



Is there a specific reason that you are using this repository?

It was just about getting support for certain addons that weren’t available for the current at the time official version. If I could, I’ll just return to the regular repo and version, but as I understand, this will require a reinstallation, and for several reasons, this is something that I would like to avoid if possible. Anyhow, I’ve always been an early adopter, so I’m used to dealing with the associated problems.


Using the development repository won’t get you access to newer add-ons, with the exception of binary add-ons as we distribute those with Kodi.

Via SSH, run:

sudo fw_setenv hdmimode=720p50hz

sudo fw_setenv hdmimode 720p50hz

This should solve your problem.

Thank you for the answer. Sadly, the command changed the way that the device is starting but didn’t solve the problem completely. Now, if the TV is off, instead of just sitting there frozen until I power on the TV and switch the Vero off and on, its LED starts flashing red and blue alternatively. While it’s doing that, I can not access the device via SSH (because the system is not booting up, or so it seems). But when I turn on the TV, the LED changes to blue, and the Vero OSMC starts up. So, the goal would be to be able to start and access the device remotely without the need for a TV to be turned on.

Sorry – please try sudo fw_setenv hdmimode 720p50hz. This should solve the problem. Note there is no = symbol.

This seems to have done the trick, thank you so much.

Glad to hear this.