BLED112 GigaBlue bluetooth low enegry USB dongle


today I received my RPi2 as well as the GigaBlue BLED112 Bluetooth USB dongle. OSMC installation went perfectly well and it works nicely. :smile:

But then I tried to setup a bluetooth connection and although dmesg shows the dongle has been added as ttyACM0 device and even recognizes the manufacturer and that it is a bluetooth dongle, hcitool doesn’t find any bluetooth enabled devices and lsusb just shows 2458:0001 with no further device information as well. :confused:

Does anyone have an idea or got the dongle working already?

We’ve not implemented Bluetooth in our addon yet but hope to get that working soon.

In the meanwhile I’d suggest

sudo apt-get install bluez




thanks but I already installed the bluez package (as well as compiled the latest one) but hciconfig/hcitool doesn’t find the device.

Output of dmesg is:

[ 817.047012] usb 1-1.4: new full-speed USB device number 6 using dwc_otg
[ 817.164546] usb 1-1.4: New USB device found, idVendor=2458, idProduct=0001
[ 817.164575] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 817.164592] usb 1-1.4: Product: Low Energy Dongle
[ 817.164608] usb 1-1.4: Manufacturer: Bluegiga
[ 817.164624] usb 1-1.4: SerialNumber: 1
[ 817.175853] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device

lsusb output is just:

Bus 001 Device 006: ID 2458:0001

So it seems as if the device is recognized and assigned the device ttyACM0 but hciconfig -a or hcitool dev returns nothing and doesn’t recognize the device correctly.

Cheers :smile:

That’s odd, does your device perhaps require firmware?



I’m having the exact same problem, did you ever get it resolved.

Exactly the same problem here too. Did anyone figure this out? Thanks

The problem that I face is this. I plugged in a BLED112 using OTG cable on a Raspberry Pi Zero. It just doesn’t show up as hci device on the RPi. The dongle and the cable work perfectly fine on Win 7 PC. And also on the RPi the device does seem to get detected as /dev/ttyACM0. I have tried this with multiple RPis and multiple BLED112. It’s the same behavior. I did a firmware upgrade on the BLED112 recently but then I have tested all the dongles on Win7 using BLE GUI Software and it all works perfectly. It just doesn’t get detected on the RPi as a hci device.

I believe the problem is that the BLED112 isn’t viewed as a bluetooth device on Pi, but rather, a USB device, or more specifically, a USB CDC device.

I too, tried to connect to it with minicom, but still no luck. Then I found a PDF entitled “USING BLED112 WITH RASPBERRY PI” (quick start guide). Install python-serial, download the sample program, and you’ll see advertisements.