Blinking sad face all the time on rpi2

hi guys!

On an rpi2 with the latest osmc i’m experiencing some weird issue quite many times.

My rpi is set to auto reboot each night, and usually by the time i switch on the tv i can see the sad face icon, blinking, like it is in a loop or something.

I tried the previous suggestions (updating the system via command line, grabbing the logs ,etc) but nothing actually worked.

SSH login error:
ERROR: object ‘/usr/lib/’ from /etc/ cannot be preloaded (cannot open shared object file): ignored.

osmc@osmc:~$ grab-logs -a
ERROR: object ‘/usr/lib/’ from /etc/ cannot be preloaded (cannot open shared object file): ignored.
ERROR: object ‘/usr/lib/’ from /etc/ cannot be preloaded (cannot open shared object file): ignored.
ValueError: bad marshal data (string ref out of range)

Do you have any idea what could possibly cause this issue?

I also tried to grab the kodi.log manually, here you are:

Any help would be appreciated.

BTW after a couple reboots it usually starts working, but have no idea what causes this glitch over and over.

A Kodi debug log is not much use for this type of problem, the system journal would be more useful. If grab-logs is not working try:

sudo journalctl | paste-log

The following would also be nice:

paste-log /var/log/apt/term.log
paste-log /var/log/apt/history.log
df -h | paste-log

I suspect your problem is going to be major file system corruption, especially given that something as simple as grab-logs is crashing due to missing or corrupt system files. If I had to guess I would say the reason is probably your SD card is dying, but its hard to know without more information.

BTW why do you have it set to reboot nightly ? That should not be necessary and if you find that it is, you are probably just masking an underlying problem.

hi @DBMandrake!

Thanks for the info, I run all the commands you suggested, here you are:

osmc@osmc:~$ sudo journalctl | paste-log osmc@osmc:~$ paste-log /var/log/apt/term.log osmc@osmc:~$ paste-log /var/log/apt/history.log osmc@osmc:~$ df -h | paste-log

Regarding the necessity of running a reboot each night, I just set it because we have a PVR and sometimes we just accidentally switch off the tv, and it keeps running in the background. So at night i just do a reboot forcing it to stop, didn’t find any better solution for that, that’s the only reason.

I can see that you have at least one banned addon installed. they are often known for causing problems.Try deleting the addon, and see what happends.

could you please help me identify which one is that?

Here is a list over all the banned repos and addons.