Bluetooth not detecting

I got the bluetooth receiver from the OSMC store in the mail. Plugged it into one of the side USB ports (the remote was in the rear one). I tried going to the MyOSMC->network menu, but it did not show any bluetooth section. Rebooted device, still not showing up.

I then tried switching the USB dongle to the rear USB port, and put the remote in the side. Now when starting up, the renote control does not work, no matter which USB port I use, even after restart.

Can you please advise what I have to do to get the remote to work again. And also if there is something else I have to do to get the bluetooth adaptor working. Thanks in advance.


I think you may be slightly confused here. The remote requires you to use the RF receiver that came with the device. You won’t be able to substitute this with a Bluetooth dongle.

To restore remote functionality:

  • Power down the Vero 2
  • Remove the Bluetooth dongle
  • Relocate the RF receiver to the rear port
  • Power up the Vero 2

Try your Bluetooth dongle in a PC or a computer to see if it’s detected. This will let you see if it’s faulty.


I simply plugged in the bluetooth dongle, I did not remove the receiver for the remote. When it did not work, I attempted to switch the positions of the two receivers, putting the bluetooth dongle in the rear port and the remote receiver in the side. However this caused the remote to stop working.

But, I connected a mouse and was able to confirm that the bluetooth dongle is now detected (in the rear USB port) and I have access to the bluetooth menu. After a while the remote started working too. So far so good.

However, I have still not managed to make the Vero 2 pair with my bluetooth keyboard (a Logitech K380). My process is: Enable bluetooth -> Start/stop pairing -> turn on/activate the keyboard. But nothing happens. Do you know if this device is supported? OR do I have to do something else?

Sometimes you need to reboot the device for the remote to work again for udev to catch the remote. I know you said that you did this in the post above, might have just been a one off problem.

I don’t know much about the K380 but don’t see why you would have issues pairing keyboards. When you say, [quote=“johnyzee, post:3, topic:18073”]
But nothing happens

Do you mean it doesn’t show up in the list of devices?


Yes, nothing shows up in the list of devices.

Okay, that’s a discovery issue.

You can try bringing the keyboard closer. If there is a button on the keyboard to make it visible, you may need to press this.

I’m not familiar with the procedure for pairing this keyboard, but I would expect you need to enable discovery on the Vero 2, and press some kind of button on the keyboard to make it discoverable.


OK, it discovered the keyboard after I moved the dongle to another USB port (whether or not that was the reason).

So next question, I feel dumb to keep asking, but: How do I use the keyboard? I assumed it would work for any text input dialog, but trying it with the youtube add-in search dialog, no key strokes result in input.

It should work in Kodi, but I’ve only tested the Bluetooth keyboards on the command line. Does restarting Kodi help?

Also – check that it hasn’t dropped the connection and you are still paired. Sounds like the most probable reason for not getting keystrokes.

It does seem to have lost connection, and does not connect after a reboot.

It blinks as if trying to pair, but does not succeed. I am also not able to repeat the pairing process - the keyboard is already on the list of ‘paired devices’, but as far as I can tell that does not mean the Vero can currently see the device. When trying to pair, again nothing shows up in the available devices, but I don’t know if this is because it has already been paired once before. I can’t see a way to make it ‘forget’ the device.

You may have to ‘Trust and Pair’ the device. This varies from keyboard to keyboard. We can also try pairing it via SSH (if you are familiar with the process) which may be more reliable.

Try removing the device in bluetooth then repair it - make sure you use the “Pair with PIN” option when pairing a keyboard, entering the PIN provided when pairing. If you use the other option it may not auto reconnect.

I use a small bluetooth Keyboard on my Pi 2 using a standard CSR bluetooth adaptor in the Pi and it works perfectly and stays paired across reboots.

Keep in mind that after a reboot you will have to press a key and wait a few seconds for the keyboard to reconnect, also if you are a long way away the keyboard may work when already connected but may fail to initially connect or pair at that range. About 3 metres seems to be the limit of some bluetooth keyboards.