Buffering on large video files since update

Hi there, Before this latest update, large mkv files with 7.1 audio (dts-hd/truehd etc) have played fine. Since I updated yesterday, i have had nothing but issues trying to play large video files (movies). They all play for a few seconds then they just sit and buffer. The do eventually play, but for maybe 10 seconds at best and then the buffering starts. I have tried many different large mks files with all of the same result.

Tv shows play fine and smaller lower res movies play fine but not large mkv movies. Everything I play is in mkv format. My full debg log is here: https://paste.osmc.tv/ovoxebeyol

I am on a 5g wifi and nothing in my setup has changed since the update. I tried playing the file from my laptop connected over the same wifi network and it plays fine. I even tried using the folder mount via FSTAB and it still has the same result.

I am using the estuary skin, and changed over to the default My OSMC to see what the AQ/VQ was and the buffer. It buffers to about 180Mb, then it runs, but then stops (buffers, AQ/VQ goes to 0) when the buffer runs out. What is weird is that when the buffer starts running out, it doesn’t try to keep buffering, it just sits there and plays until the buffer is gone. The files are shared from a windows 7 desktop with usb hard drives. The setup has worked until yesterday/today.

I also got a sad face when doing the update. The sad face came on, said please report this to the osmc forum, then the screen went black, the box rebooted, then came back and I assumed everything was ok.

Any help, much appreciated!

What is the server you use? Which OSMC version you used before this update?

Hi there. I use a Windows 7 desktop with 2 usb hard drives attached as my “server”. Shares are shared out through SMB.

The OSMC version before this was December.

I am using an OSMC 4K box.


There shouldn’t be any major change in January that would cause that especially if Kodi and fstab both give you issues. What I suggest:

  1. Check the enabled SMB protocol on the Win 7 machine
  2. Check the wifi throughput between the Win7 and the Vero with iperf3 for 5 minutes
  1. I am assuming SMB 2.1 as there is no registry key in my registry to check as per this technet article for Windows 7. How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows | Microsoft Learn

  2. Iperf test: [ ID] Interval Transfer Bandwidth Retr
    [ 4] 0.00-300.00 sec 1.97 GBytes 56.4 Mbits/sec 0 sender
    [ 4] 0.00-300.00 sec 1.97 GBytes 56.4 Mbits/sec receiver

This is 1080p content, no 4k or anything like that.

Also, why doesn’t the buffer try to keep the buffer full? Why does it fill up, then wait until it runs out, then refills the buffer?

While it looks a low reading for 5G it should be OK for 1080p content.
I am still confused why Kodi and FSTAB should be impacted. Two more test suggestions

  1. To test fstab performance dd if="/mnt/Big_Movies/<movie_name>" of=/dev/null status=progress
  2. Change in Kodi Settings the max SMB protocol to 2 and second try 1 and see any change in behaviour.

fstab perf: osmc@osmc:~$ dd if="/mnt/Big_Movies/Black Mass (2015)/Black Mass (2015).mkv" of=/dev/null status=progress
342647296 bytes (343 MB, 327 MiB) copied, 87.0005 s, 3.9 MB/s^C
672113+0 records in
672112+0 records out
344121344 bytes (344 MB, 328 MiB) copied, 87.1483 s, 3.9 MB/s

It went between 3.8-4.2MB/s

  1. i edited this file /etc/samba/smb.conf. Is that the correct file? I am unsure if you have to restart any services for it to take effect. I reran it with pretty much the same results, just a bit lower. 3.6-3.8MB/s

You’re using the default block size of 512 bytes, which will be very inefficient.

Try adding bs=4M to the command and see if it makes a difference

Hi there. With the bs=4M flag:

406847488 bytes (407 MB, 388 MiB) copied, 91.2456 s, 4.5 MB/s

A bit better, but not substantially much.

Is there a way to go back to the Dec version? Unfortunately, I didn’t make a backup, but I really don’t have anything on my box that I can’t put back. Everything worked fine with that version

4.5 MByte/s is roughly what I would expect if your WIreless gives you 50Mbit/s
But for 1080p that should be fine.

No, I don’t suggest to change anything on that file (if you have done revert it back).
I meant going back to your original solution that you are playing with the Kodi buildin SMBClient.
Means change it under Settings -> Services -> SMBClient -> Max Protocol Version.

Well the easiest is to make a Backup from MyOSMC reinstall December Image and recover the backup. That will backup all your Kodi settings you only lose OS settings and programs you installed

The SMB version was set to SMB3 in Kodi. I changed it down to SMB2 and restarted. No difference.

What is interesting is that I went into My OSMC and went to updates. It actually found updates which is odd as it did the January update. So I let it update what it needed to and now it is better but not totally fixed.

The buffer does fill and tries to stay full, unlike before… i can go almost 20 mins without another buffer but it isn’t buffer free like before the update.

I think something went sideways on the update and it is a half baked update for lack of a technical term lol.

If I can just go back to factory, and start over I think that is best. I’ll use FSTAB right off the hop. About the only thing i would want to save is the favourites if I can. The other stuff isn’t a big deal.

is there a link that can walk me through going back to December?


That is strange, maybe upload grab-logs -a to check what happened

What is the mediainfo of the file you are trying to play?
Please see the mediainfo section in How to submit a useful support request - General - OSMC

If you do the backup via MyOSMC (save the backup to your NAS) all Kodi settings including Favourites will be saved.

Logs are here

I got this vero4k for a Christmas present from the wife. I did two system updates that went fine Oct, and Dec. This one seems to have gone a bit weird.

I’ll get the media info and do a backup tomorrow. For the December version, do i download the disk image 2017.12-1? or just use the installer for Vero on the top of the page.


Just the installer (not for Vero but for your PC Platform eg Windows). You then in the installer can choose the image you want to install on the SD card.

Actually that second update was normal. I had checked my Pi3 instead of the Vero4k. For the Vero4k Sam last night released another update to fix an issue on the resolution downgrade.

Ok, excellent!

That update makes sense then for the Vero4k box. Still very strange!

Im having a similar issue…was there ever a solution to this other than reverting to a previous version?

In my case, everything worked fine, now, all larger files, regardless of 1080p or 4k, stop after 3-4 seconds of playback. Then, after 20-30 seconds, the buffer fills and everything is fine again, including if skipping forward (as it seeks and finds and fills the buffer right away).

It seems to only be on initial file load. Very frustrating.

I get the sad face every time after an update and have noticed lots of weird issues, especially with buffering. Even though mediacenter reloads after the sad face I always do a reboot afterwards and that seems to rid the system of any gremlins post-update and buffering problems go away.

Sad face after update is a bug and can be ignored.