[BUG] Soft Freezes All the Time (Two RPis)


Been using OSMC for a long time and generally it’s been stable, recent updates have made my system entirely unstable.

A little inconsistent as to what triggers problems but behavior is similar:

Videos: Say “loading” but never actually load, remote (Yatse) becomes non responsive, can SSH into machine, killing kodi fixes it (no hard reboot). Generally I know this is going to happen in advance because the GUI sounds stop happening (i.e., I start navigating and I don’t here the GUI sounds, at that point I know it’s not going to work)

Audio/Music: This is much more frequent. Start playing something, it will play for 1-4 seconds and then sound stops, the progress bar stops, lose functional remote through Yatse, can SSH into it but I have to do a full reboot. I’d say this happens multiple times a day.

Log of when audio fails: http://pastebin.com/7EzHcNdz

This looks troublesome:
17:26:50 78735.218750 T:2602066928 ERROR: COMXCoreComponent::WaitForOutputDone OMX.broadcom.audio_mixer wait event timeout 17:26:50 78735.218750 T:2602066928 ERROR: CActiveAEResamplePi::Resample m_omx_mixer.WaitForOutputDone result(0x80001011) 17:26:51 78736.234375 T:2602066928 ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_mixer wait event timeout 17:26:51 78736.234375 T:2602066928 ERROR: CActiveAEResamplePi::Resample m_omx_mixer.GetInputBuffer failed to get buffer 17:26:52 78737.250000 T:2602066928 ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_mixer wait event timeout 17:26:52 78737.250000 T:2602066928 ERROR: CActiveAEResamplePi::Resample m_omx_mixer.GetInputBuffer failed to get buffer 17:26:53 78738.273438 T:2602066928 ERROR: COMXCoreComponent::GetInputBuffer OMX.broadcom.audio_mixer wait event timeout 17:26:53 78738.273438 T:2602066928 ERROR: CActiveAEResamplePi::Resample m_omx_mixer.GetInputBuffer failed to get buffer 17:27:02 78747.695312 T:3024290736 DEBUG: SELECT albumview.*,albumartistview.* FROM albumview LEFT JOIN albumartistview ON albumview.idAlbum = albumartistview.idAlbum WHERE albumview.idAlbum = 1047 ORDER BY albumartistview.iOrder

Someone in the forum said “likely hardware” so I spent 4 hours setting up a second Pi, different SD card, same exact problem happened within 2 minutes.

1 Like

I suggest you take out the overclocking and also please upload full logs using the OSMC uploader (either from within MyOSMC or on command line grab-logs -A)

Sorry I should have said I already tested without the overclocking and that didn’t resolve it. As for the full logs, do I have to enable logging in system still?

Yes, enable debugging. Make the problem appear and then (best being logged in via ssh upload the logs with grab-logs.

Will do. I’m sure the problem will happen within the next hour or so. As soon as it does I’ll report back.

As promised - log is available here (this is from a video failing to play): http://paste.osmc.io/hexegesiso

What I did:
(1) rebooted Pi after enabling silent logging;
(2) Left Pi alone for about 30 minutes while I was doing other things (nothing playing at all)
(3) Came back to Pi - noticed GUI sounds were not happening;
(4) Picked a video, tried to play it
Result: “Working…” shows up on screen, nothing happening

1 Like

Set resample quality from GPU to medium (in system/audio settings).

Testing now - will report back to say it worked (if I can go whole day without a problem) or will come back saying it didn’t. I switched to my other Pi again so reinstalling now.

Thanks !

and I’m back - happened again about 5 minutes ago :-/

I have exactly the same problem.

CActiveAEResamplePi::Resample m_omx_mixer.GetInputBuffer failed to get buffer

I have suspicion that this is problem with allocating memory.
My Pi has 512MB, in config.txt gpu_mem_512=144.
During error I have abou 49MB free memory.
My OSMC installation except kody also run transmission server, samba, and java process.

Did you try the suggestion a few posts up?

I did and it didn’t resolve the problem.

I also did it, now durig movie playback i get:

ERROR: CDVDPlayerAudio::DecodeFrame - Decode Error. Skipping audio packet (-1094995529)

I dont know if it matter, but now I am using external i2s sound card.

I get the same error. Music, whether it be ripped cd, podcast or Internet radio plays for a few seconds and then everything stops. I have to power off and restart.

No problem with steamed video or ripped DVDs. This PI been steady as a rock for over a year until the April update

Additional information here. The problem is almost always reproducible with the following steps:

  1. Go to music (local);
  2. Play a few songs;
  3. Go back - scroll to tv shows

Observed: Sound stops working after scrolling through tv shows a bit - no need to go into the show themselves, just go back and forth between two shows a few times

  1. Try playing an episode

Observed: Pi just says “loading” but never loads anything, ssh works, reboot required to get functionality back

It seems to be an interaction between videos and music (I believe doing the opposite steps - starting with a show or two, then moving to music, results in the music cutting out and requires a reboot also)

Has anyone tried going back to an older version of OSMC to see if that resolves the problem? I’m having to reboot a dozen times a day right now which obviously makes OSMC much less fun :frowning:

Hello, experiencing most probably the same problem (rpi3, hifibbery amp+ for sound). Kodi freezes several times a day, usualy while just playing music, sometimes while playing video (mostly youtube plugin). I use photoslideshow (see in logs) but turning it off doesn’t influence anything. Here are my grabbed logs: http://paste.osmc.io/xuvobibuke hope it helps to find out the root cause and the fix.


Same here, raspberry pi 3 model B it happened during audio playback while I was away.

17:12:25 190593.718750 T:1574958064 WARNING: JpegIO: Error 53: Not a JPEG file: starts with 0x%02x 0x%02x
17:12:25 190593.718750 T:1574958064 ERROR: Texture manager unable to load image from memory
17:52:05 192973.140625 T:1564472304 ERROR: COMXCoreComponent::WaitForOutputDone OMX.broadcom.audio_mixer wait event timeout
17:52:05 192973.140625 T:1564472304 ERROR: CActiveAEResamplePi::Resample m_omx_mixer.WaitForOutputDone result(0x80001011)

The “JPEG error” makes me think that it may be something totally different …
Like some bad album image. (I was playing a giant 4700 items playlist randomized) Any way I can prevent kodi from reading those ?

Just an update here.

I’ve been using a build from February without a hitch for the past month. Decided to try to update today and within 10 minutes had a freeze again. Went back to the february backup that I have and it’s running fine.

Happy to do further testing with guidance.

Please test with the June release which is due later today.