Build-environment fails to install on debian stretch amd64 vm and real

Hi @all,

got a little problem with buiding the environment, always fails at the same position, when openjdk-8-jre-headless:armhf is setting up ca-certificates. Log is attached at

Build it on a real AMD64 machine, not under emulation

Hi Sam,

ok, give it a try, thx.


Exactly the same on dedicated amd64 with exactly the same log.

No success at all.

I’ve tried several kernels and distros, with Mint 18.3 no prob with openjdk, but nevertheless success, does qemu: unsupported systemcall: 384 affect it in any way?


Die folgenden NEUEN Pakete werden installiert:
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.
Es müssen 63,1 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 251 MB Plattenplatz zusätzlich benutzt.
Holen:1 stretch/main amd64 armv7-toolchain-osmc all 1.4.3 [63,1 MB]

Looks like you’re trying to build for ARM.
Do this on an ARM device preferably.

I thought you were building for PC

Ok, I’ve thought it’s the same as with dreambox, there it’s no prob to build on amd64 the whole image.
Thx for pointing me in the right direction. Could u eventually make that possible somehow, cause otherwise i have to invest in a second vero or raspi, at the moment it’s a bit difficult. :wink:


The toolchain is completely isolated.
You can build on PC, but you’ll need specific QEMU packages; and ideally, you’ll want to build using Debian 9 as the main OS.

That’s exactly what i wanna do. :slight_smile:

I would advise building it on a arm processor. It’s going to be as slow as hell emulating it.

I also got the same error you got on the VM. Just rerunning the make again and it goes through. Probably some java bug.

It’s a bug with pthreads in QEMU. It seems to be fixed on newer versions of QEMU but some distributions have older versions

Ok, i see, that’s the reason why it’s functioning with Mint i guess.

Mission accomplished! :smile:

I gave Linux Mint 18.3 a try and it did it because of the newer packages, so if anybody plans to crosscompile leia on pc for vero, i’d consider to take the latest Ubuntu or Linux Mint, because they are the same. I’ve spent 3 days to figure it out, but now my first package is lying in the path!

Qemu packages i’ll build in an vm first, but the main thing was getting leia out of pc. :wink: Next thing will be to get rid of that annoying syscall-thing.

My bad, it’s no crosscompile-toolchain, that’s all, took a while to get used to the build-system. :slight_smile:

Solution: [HowTo] Emulating Debian Stretch arm64 on a x86_64 Linux host