Can I use Netflix on OSMC?(post 4)


I have got this same, after update i cant even login to netflix


Update your addon:


Settings->Addon browser->Install from zip
navigate to home folder, choose


That worked perfectly! Thanks a lot!


For me too :grinning: thanks



I get fail when I try to install from zip file the netflix plugin. Any suggestion?
I have Kodi 18 and the latest version of OSMC


Enable debug logs, restart mediacenter (Exit in Power menu), retry the installation. Upload logs via MyOSMC or “grab-logs -A” in command prompt. Provide the URL given, here.

Edit: Did a clean install and had to manually install all the required addons for netflix addon, check this post:

But i got problems getting it to work, had to downgrade the script.module.request to get it working. Did get the (which didn’t work, did).

Got a working Netflix add-on, on a fresh install


When I tried again to extract the logs, it worked. This happened 2 minutes ago.


Hi there! First of all thank you for your wonderful work joakim_s, I have been using this addon for a while now and it is just awesome! Do you know when it will be included in the official release?

I reinstalled everything on my Pi today (I wanted a double boot with Raspbian and OSMC) and even if I manually pip-installed all the dependancies I am still getting a failed installation of the addon!

From the logs ( it looks like the requests module is not recognized from the system although from command line it looks fine to me…

Cheers from europe!


I dont know what happened again, but now i am getting lags when i am watching something on Netflix.
The video starts fine but after 2-3 seconds the image is lagging behind. If i fast forward to 10 min again the same thing happens.
It’s not the bandwidth…and i’ve tried both movies and tv-shows.
Btw when i am watching something from LAN shares everything is fine.
ps: No errors in the log…

Anyone else noticed anything similar after that last osmc update?


@maik sorry can’t help this weekend, I’m about 100km away from my setup at the moment. Will get back to you Sunday evening or Monday afternoon.


No worries! And no need to say sorry! I’ll keep on trying! :wink:


Slightly related - what add on should I be using for Amazon Prime? Thanks


Everything is working fine for me… the only issue is that when I try to add subtitles.

It has just German, English, Hungarian, Polish and Turkish but I can’t find Romanian.
On iOS , Web and my SmartTV the movie has Romanian.

I was trying to use but it’s taking time to do this for every episode from House of Cards for example, because they are not synced so I need to find a good version and also to sync.
For normal movies OpenSubtitles is a solution.

Do I have to do some settings in Netflix addon so that also Romanian language will appear?


Thats probably because Netflix has the Romanian subs as images and not text, so they dont show up on kodi addon since it works only for text. Same thing happens with Greek letters.
Eventually there will be a feature that will convert the images to text although i think downloading 120mb of images while the movie starts will be a problem whichever way you look at it.


So the lag i was getting when i was watching netflix was because i had 1080p resolution on my Display settings. Lowering down to 720p fixed all the lagging.
What resolution do you guys use ? Am i the only one here that his pi3 cant cope ?


1080p isn’t possible on Pi


@maik have you tried this:


Hi, i dont change anything but netflix stops working. I can’t even login. Do You have this same issue ?


Will try to look into it tonight


Is 1080p possible on the Vero 4K? If so how do I enable it?