Can I use Netflix on OSMC?(post 4)


720p is possible for now.
You can enable 1080p but it may be choppy. We are working on some improvements, but no guarantee just yet.


Thanks Sam - how do I enable 1080p?


Set it under widevine CRM settings.



And is that a setting within the netflux addon?


No — it’s under the Widevine addon



Hi, do You know what is the issue ? Anybody has this same problem ?


Will do a clean install and check it right this moment, been pressed for time the last week.


thanks :slight_smile:


Latest leia, i can login but when it’s time to start playing i get sad face.

have you tried Switch accounts alternatively Logout, from netflix setting page?



To change resolution you go,
Netflix settings, Account, Inputsream Addon Settings…


i cant logg off because setting page is a mess and i cant do anything, i try install new system updates and now OSMC is not booting :confused: only sad face …


i get error ‘failed to install a dependency’

opening the log file
12:42:23.412 T:1917562880 ERROR: Error parsing boolean expression container.content(addons) + integer.isgreater(container.numitems,1) +
12:42:38.685 T:1560142576 ERROR: Requested path not found in known repository directories
12:42:38.685 T:1560142576 ERROR: CAddonInstallJob[script.module.requests]: failed to resolve addon install source path
12:42:38.689 T:1560142576 ERROR: CAddonInstallJob[]: failed to install dependency script.module.request

link to a log file


Try solution on post 142 in this thread

don’t know if it’s leia or something else that makes it happen, but has happened to me twice, but last time the install worked without having to manually install every dependency


Yes I get the same problem if I restart my Pi. But normally I am eventually able to log in, or I restart the Pi and I can


Latest build from gmc and i got it working again.


After the latest update I was not able to start Kodi at all… the sad face appeared over and over again. I decided to install Kodi 18 again on mi Pi3.

But now I can’t install netflix plugin anymore.
Link to my log file:


16:58:35.536 T:1603269360 ERROR: Requested path not found in known repository directories

Read post 142, problem with manual installation of dependencies . Seems to be a little random when it happens or not.

But after installing i notice a lot of login issues with netflix addon, even had to uninstall and install again to login, tried logout and switch account sometimes that works other times not


I have the same issue on a pi3, did a clean install, got netflix working. Said yes to a monthly update. Now a sad face at startup.
Should i start over again?


I started again the installation from 0, but right now I can’t install Netflix plugin. It always fails when I am trying to install. For now I don’t use Kodi for watching Netflix anymore. Don’t know what do advise you. Maybe someone else has a solution


@alexpad check log for error, if it’s somethign like this there, try post 142 in this thread