Can I use Netflix on OSMC?(post 4)


#329

Apologies I thought you were involved… Thanks for the link


#330

just tried it , works 100% at 720p

thank you!!!


#331

Hi guys, I want to use netflix on my Pi. I followed the guide which is basically these steps

echo "deb http://download.osmc.tv/dev/gmc-18 gmc-18 main" | sudo tee -a /etc/apt/sources.list
wget -qO - http://download.osmc.tv/dev/gmc-18/pubkey.asc | sudo apt-key add -

sudo apt-get update
sudo apt-get dist-upgrade -y

sudo apt-get install python-pip python-crypto build-essential -y
sudo apt-get install python-all-dev python-setuptools python-wheel -y
sudo apt-get install python-crypto-dbg python-crypto-doc python-pip-whl -y

pip install pycryptodomex
sudo ln -s /usr/lib/python2.7/dist-packages/Crypto /usr/lib/python2.7/dist-packages/Cryptodome

wget https://github.com/kodinerds/repo/raw/master/repository.netflix/repository.netflix-1.0.1.zip
wget https://github.com/Sandmann79/xbmc/releases/download/v1.0.2/repository.sandmann79.plugins-1.0.2.zip

sudo reboot

Now the issue is that I can log into netflix but nothing happens when I try to play something, if I am correct I should see a prompt to install widewine right?


#332

I’m haveing issues as well, and I’m not in position to make a clean install the next couple of days.


#333

I’ve just made a clean install of OSMC on my Pi3. I updated to nightly and then ran my netflix-prep script(in post 4, after upgrading to nightly), installed the latest netflix addon(0.13.22). Logged in and when I chose a show it asked to install widvine, after that the show played as it should.


#334

Just tried it but got the same issue, I can login to netflix, click on something to play but then the screen loads and comes back to the previous state and nothing happens after that, I don’t get the prompt to install widewive.

Is there a manual extraction method that one could use instead?