Can not add SMB locations

I have googled for hours and read anything I could find about SMB paths to try to make this work, but it just won’t. I have been trying to add my PC, Laptop and MyBookLive to the library on my Raspberry Pi 2 running OMSC. Everything is updated, and all three are in a Windows Workgroup and work between the three of them.

When I try to add it, I go to add location → Browse → SMB → Workgroup → Pick either of the three, and this is where it stops working. It either freezes completely, sometimes it lets me click it again and then it asks me for a username and every 10th time a password. I have tried putting in the windows combination and (as I read in another topic) the samba username/pw and neither of them work. Generally it doesn’t let me do anything else any more, I can’t return to the main screen, can’t stop what it’s doing, nothing. I tried waiting for 10-15 minutes to see if maybe it was REALLY slow, but no. I have the Kore app on my phone that works fine on the Pi. I have also tried changing the username and password in the Pi to something random to see if that solved the problem, but it didn’t.

I have the same setup (power, SD-card, OSMC, etc.) as my brother, since he knows more about this and he set it up for me. Also updated OSMC today. Everything works fine for him, but somehow it will not let me add these other PCs to the library.

Anyone go any ideas on how to fix this? I’d love to give you guys on of those links but I have no idea on earth how that works. :confused: Thanks in advance!

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

I have tried to put as much information on it that I can. When I say upload logs, it gives me: - but this one doesn’t work for me. Maybe it does for you. As for the command it says at the bottom, I’ve been trying since I posted this so I hope this helps: . It seems pretty generic, and I don’t know much about command logs so I’d rather not mess around in them. If you want me to use a specific command and copy/paste it let me know.

grab-logs -A

Thanks a bunch, I feel like a noob. :slight_smile:

This can be done by going to Settings -> System -> and selecting Enable Debugging.You should then perform a reboot of your device and perform only the minimum actions required to replicate this issue

Where is the failed attempt to add a samba source??? It’s not demonstrated in those logs…

I did all of that. To be sure, I checked the settings, rebooted, and tried to add the samba source again. This is the log I got:

But as I said, I’m not sure it wills how up as a failed attempt, it doesn’t say it failed. It just stops responding. I can hear the sounds when I click on a button, but it doesn’t let me do anything. Except very randomly and only very sometimes when I select it and it will ask for a username or password.

all it is permission errors are you trying to log on too your windows machine or nas ?

if its windows 8 or higher remember then that its your first name and password

first name being whatever you specified at the time when you installed windows.

1 is a Nas, 1 is windows 7, 1 is windows 8. They all give the same problem.

Even when I try to log in to the Windows 8 PC and give in my first name + password that is set up, it’s not working. I don’t get a screen where I can give in username + password in 1 screen like I’ve seen in other peoples screenshots. It’s first a screen for username, then if I’m lucky enough after a lot of clicking I get a seperate screen for the password, where it doesn’t let me change the username anymore either. But most of the time it just keeps opening the screen for just the username, where it shows what I already filled in and keeps doing that. I also specifically checked the username/password for the nas, but those will also not do anything.

I’m going to give a post from 24th June 2014 here a try for this on one of my PCs.
You might want to check it out

Thanks for all the help guys. I think I will let someone else look at it. :slight_smile: