Can not install Cayenne MyDevices

The funny things is that I know about Cayenne from a subscription mail from OSMC with Cayenne advertising :-& It was that mail we get on two years anniversary last days.
I have done all steps to install Cayenne on RPI 2B, using Android application, and everything seems to be done right - all steps with no errors. Then I see a info on that application, that it waits to rebooting RPI. The RPI reboots indeed, but the application is still waiting, with the same info: waiting for robot…
Is there any way to install it? Where is any docs showing parameters needed by Cayenne?

I am not sure if @sam_nazarko might already have checked out Cayenne.
So I assume you have the SSH service activated on OSMC and you gave the Cayenne App the OSMC user credentials.
Could you try the second method, the command line install as that might be giving a clearer view of what happens.

I believe you need Raspbian (or a desktop environment) to properly use Cayenne.

That’s good idea, I will try this evening. Thank for the advice!

I belive that if good people from OSMC team are sending special mails for second year OSMC celebration with a commercial (advertising) of Cayenne - so Cayenne must work on OSMC :wink:
I was writing also on Cayenne community - will let know when we find solution, Cayenne is worth of it and - most of all - OSMC is worth of it :slight_smile:

Cayenne ran a sponsored advert on the forum for 30 days, and a Newsletter advert. I thought it was a good pick, as it was Raspberry Pi related, which is more relevant than most Google Ads.

This video may help:

I know this video. After step 4 there is info “RPI needs reboot” (cutted off in this video). RPI really reboots…and nothing more happend.
I was installing using command line now (not by the Android app), I attache the screen - similar, rebooting RPI after all steps and no more at all…
Something make me terrified - the script I run from putty is comunicating with the browser (as you see on the screen)…well, I wonder how they do it, how do they know to get to my specified Tab in browser…magic :-/

For Python development headers, run sudo apt-get install python-dev

Don’t get why they check for 2.7.x headers but run python3.

Hello again,
Installed Python2 and 3, then errors, so ‘apt-get -f install’ to resolve dependiences errors, that again Python2 and 3 - successfuly, with no errors, that again instalation of Cayenne (wget
and sudo bash -v) and the result is like on the screen - RPI rebooted indeed, but… nothing else happend, the www site non stop shows “rebooting Pi”… Watchin that errors on Putty I can see that there is still problem with building for Python (why?).
After all that installation of Cayenne using Android app in not possible now - it says that ssh user / password are problem (but no one of the has been changed).

It doesn’t seem like you tried to run this on Raspbian

You probably need build-essential and a variety of other packages. OSMC is quite cut down.
Would need to see a full log to know the issue. I don’t like the fact the script is trying to use cross… So export CROSS_COMPILE=/usr/bin/ would overrride that.


How to send you a log? The forum not allowed me to attache .txt file :frowning:

There is a topic with more logs from other users on Cayenne forum (regarding to installation of Cayenne on OSMC):
Maybe will help to find solution. Heaving Cayenne on OSMC would be great :slight_smile:

There is suggestion on Cayenne forum, that OSMC’s firewall could block. Is there an firewall inside OSMC set to block everything? Could it be changed by user (how)?

Post it to and provide the URL here.