Can watch 1 episode, then no more!

This is kind of a bizarre problem that I have done some searching around for and not found a solution yet.

This problem started today, before today everything worked just fine. Here is my setup -
Raspberry pi 2 with osmc installed
Windows 7 server setup with smb shares and static IP address

Until about 5 hours ago, I was able to watch episodes of tv or movies off of my server just fine connected to the raspberry pi. This has been setup over 1 week with no problems. Just recently however I am only able to watch one episode, and then no more. It says unable to connect to server, or gives it an invalid argument error.
I am connected using the IP address, not a hostname that needs to be resolved. Nothing in my network has changed, and none of my ip addresses have changed as they are all static and reserved.
The only way I can get it to work again is by resetting the server, after which I can watch 1 more episode and then nothing more. I have tried to reset the pi to no avail. Only resetting the server will resolve the issue.

What is more odd is that I can connect to the server just fine on any other device on my network including mac, windows, and a linux OS.
I am fairly new in the world of linux and do not know much, but I will do my best to provide any information that I can. Any ideas? Thanks

Please provide logs when the problem happens. Are you using samba?

Try rebooting the windows 7 machine. If that fixes it see: