Cannot connect to NFS share, Samba works

I’ve mapped my NAS shares via SMB which works fine.
I want to switch to NFS, but can’t get that working. When I click Files -> Add -> Browse, then NFS, nothing happens.

Checked the log, it mentions nfs_mount_async failed kodi

Also tried adding nfs://ip-address/share directly but doesn’t work either…

I’ve configured NFS properly, i.e. added IP address.
It works fine from my Ubuntu server.

The only difference is that my NAS is at 192.168.1.x, my Kodi is at 192.168.2.x behind another route. But as said, works fine with SMB.

Well SMB and NFS uses different ports therefore that might be an issue.
I suggest you first try a fstab based mount for the NFS share because that gives you more chances for troubleshooting and also would be more performant.

I’ve done this on my Ubuntu box, but there are different ways to do this… Haven’t accessed my Vero via SSH yet. How would I add this mount?
Thanks for the prompt reply!


This could be a browsing issue, you may find if updated sources.xml manually, you will be able to access you nfs share. The easiest way to this is via the command line.

nano ~/.kodi/userdata/sources.xml

Make your changes, ctrl -x and yes to save.

It will want to look something like this:

    <default pathversion="1"></default>
        <path pathversion="1">nfs://192.168.1.x/volume1/video</path>

If that doesn’t help then you will need an entry to your fstab as fzinken suggested.

sudo nano /etc/fstab

You haven’t given us much detail about the nas, but I’m guessing the entry will be something similar to this

ip:/path/to/nameofshare /mnt/nameofshare nfs x-systemd.automount,noauto,ro

you will need to sudo mkdir /mnt/nameofshare

restart the vero4k

To add the video source in kodi: you browse to the root file system, mnt and nameofshare.

Thanks Tom.

You have a few roadblocks:

Kodi will only see an NFS share on the same subnet, so won’t see anything on subnet 192.168.1.*. So you’ll need to use /etc/fstab for NFS access across subnets or edit sources.xml as Tom has suggested.

If you’re restricting access on the basis of IP address in /etc/exports, the NAS will probably see requests as coming from the router, not from the Kodi box

It would help if you show your /etc/exports and /etc/fstab files.

Thanks all! I’ve tried via sources.xml, getting “Couldn’t connect to network server”.

I’m configuring my QNAP NAS via UI which requires IP addresses.

@dillthedog great suggestion about that IP! I have tried the router IP, that didn’t work either. Then just tried * and that works :smile:
It’s only accessible internally so that’s fine for me. It works!! Thanks guys!

If you’re running double NAT, the router for subnet will have an IP address of 192.168.1.x on the subnet.

Ah yeah of course… I’ve never had two subnets, long story why I have it now, thanks!