Cannot find subtitles with Vero 4k


I formerly used OSMC with RPI. Searcing and downloading subtitles worked great. However, after upgrading to Vero 4k, for some reason I am having great difficulty to find matching subtitles from my favorite services and

  • The subtitles search usually results in an empty list with no results (even though with manual check on the sites there are tons of subtitles for the movies searched).
  • Sometimes I get subtitles for some TV series while watching movie.
  • Sometimes I get an error message “couldn’t detect episode”, even though I am watching a movie with no reference to any episode etc. in the OSMC source folder or file path.
  • Very rarely like 10% of time I find the correct subtitle for the movie. Even on these cases the search result list is usually shorter than should be found from the sub site.

I believe OSMC might be treating movie files as TV series episodes and thus cannot find any subtitles?

I have checked multiple times:

  • the movies source folder on my NAS is marked as movies. I even removed it and added again.
  • Movies are shown correctly in OSMC library.
  • I have also checked language preferences multiple times and hits should be found.

Otherwise Vero 4k has been a great product and a nice upgrade from RPI.

Any ideas to try for finding subtitles? Thanks!

I was never able to get the addic7ed addon to work on my veros even after proving login data. Subscene does work but you sometimes need to run the search multiple times to get results.

Ok! I haven’t provided credentials for addic7ed and I think I’ve got some results with that anyway.

When I run manual search with some very simple strings, I only get results of TV series episodes. Not movies :frowning:

addic7ed Specializes in tv shows so you won’t find many if any movie subs there. Subscene is the place to go for movies