Cannot get to my Samba share after 22 March 2017 update

Since today’s update I cannot get to my music or movies on my SMB share in Windows 10 from my Pi3. According to the log it cannot reach my PC. Did anything change in the way SMB accesses the WINS server? The network is connected and I can SSH into the Pi with no problem.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

The issue you are currently experiencing with OSMC - Any music or movie I am trying to play gets stuck on “Accessing Media Info” until it ventually times out with "Playback Failed"
What you were doing when this issue occurred - Trying to play music after the latest OSMC update.
Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue. - I am not able to access anything from my Pi3 that resides on my Windows 10 SMB share since the update. I re-booted but the problem persists.
The device you are currently running OSMC on - Raspberry Pi3
What peripherals are attached to the device? - A USB Keyboard and an Ethernet network cable.
Has this issue been introduced by a new version of OSMC? - Yes When did the issue first appear and can you recall a time when it was not present? - I was playing my music today without an issue accessing my SMB share. Then the automatic update happened and after re-boot, no more access to SMB share.
Logfile

Never use host names for Samba shares. You are lucky when it works and it can break anytime

Without a debug log, it’s hard to see the issue. Did your Windows 10 PC update recently too? Try a command line mount or fstab to rule out connectivity issues

Hi Sam. See my previous reply for the log. I never had a problem with Hostname for my shares until the latest update. I have been using it like this for last few years. I have not had any Windows update today, and this problem started today after the OSMC update, so I don’t think it is Windows related. However, I will try your suggestion…Thanks for the prompt response.

Please read my link again re: enable debug logging.

Hi ActionA, not sure what I am missing. I activated logging, created the problem and went to My OSMC to upload the log. It gave me a URL which I pasted into my post. Where did I go wrong? If I click om the link in my post I get a logfile.

I have now also put the code given (iburexunol) in the Paste Bin if that is what I missed.

Maybe you’ve been very lucky, but it is definitely the problem!

19:41:29.647 T:1759806448 ERROR: Unable to lookup host: 'HOMEPC64'

Is the entry from your logfile.

There are two options, change the paths in Kodi to use smb://IP.OF.SAMBA.SERVER/… or add a line in /etc/hosts that maps HOMEPC64 to it’s IP address.

Either way HOMEPC64 will need a static IP.

Thanks sam and yknivag for your constructive input. Both of your suggestions solved the access problem to the host PC. Then I found something strange. When I select a Playlist and press “Play”, it is stuck for about 75 seconds before it starts playing. When I looked at the log I saw that there is a Wake-on-lan request that is timing out. I went back to my System Settings–>Power Saving and disabled “Try to wake up remote server on access” and this resolved the issue. This was a setting I used in the past to wake up my PC when in sleep mode. This clearly no longer works.
Thanks again, everything now working as before.:smiley: